PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
rt2500 na 2.6.16.45-1
Autor Wiadomość
mcm 

Dołączył: 12 Kwi 2006
Posty: 28
Wysłany: 11 Czerwiec 2008, 00:06   rt2500 na 2.6.16.45-1

kernel 2.6.16.45-1, arch athlon, AC
Posiadam karte DWL-G122 (Ralink na USB), która wymaga sterownika rt2500.
Niestety na poldku tych sterowników nie ma, próbowałem budować ze SPECa (auto-ac-rt2500-1_1_0-0_b3_3) i z jakiegoś RPMa (w tej chwili nie pamietam skąd go wziąlem) pod nowszą wersje jądra z wymuszeniem ignorowanie zależności.
Wersja z RPMa wywala mi przy RaConfig2500 interface not found bodajże (nie pamiętam dokładnie bo usunąłem), ze SPECa przy opcji --with kernel wywala sporo błędów (i warningów) w kodzie.
Buduje przez builder -bb -r auto-ac-rt2500-1_1_0-0_b3_3 rt2500.spec --with kernel
Pare przykładowych warningow i errorów:
Cytat:
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp.h:58:6: warning: "LINUX_VERSION_CODE" is not defined
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp.h:58:28: warning: "KERNEL_VERSION" is not defined
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp.h:58:42: missing binary operator before token "("
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c: In function `RT2500_probe':
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c:110: error: structure has no member named `slot_name'
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c:122:10: warning: "LINUX_VERSION_CODE" is not defined
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c:122:32: warning: "KERNEL_VERSION" is not defined
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c:122:46: missing binary operator before token "("
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c:229:5: warning: "LINUX_VERSION_CODE" is not defined
/root/rpm/BUILD/rt2500-1.1.0-b3/Module/rtmp_main.c:229:27: warning: "KERNEL_VERSION" is not defined

Nie chce sterowników przez ndiswrappera i skończyły mi się pomysły już jak to można rozwiązać, prosze o pomoc.
 
 
qwiat 

Distro: PLD 2.0;3.0
Pomógł: 23 razy
Dołączył: 11 Lut 2006
Posty: 367
Wysłany: 11 Czerwiec 2008, 02:10   

masz zainstalowany pakiet kernel-module-build? Jest konieczny do zbudowania każdego modułu "z zewnątrz". Więcej o budowaniu:
http://pld-users.org/doku...rdowego-kernela

Z resztą po co budować? Moduły dla Ralinka są częscią kernela od (ZTCP) 2.6.24, tak więc możesz sobie zainstalować kernel z 'ac-test' i działa :) . Jeśli to możliwe to wybierz kernel-vanilla, bo standardowy ma obsługę linux-vservers co powoduje ubicie maszyny na twardo.

PS. Jako, że w nowszych kernelach Ralinki są jego częścią, to urządzenia przedstawiają się po ludzku czyli wlanX zamiast raX.
 
 
mcm 

Dołączył: 12 Kwi 2006
Posty: 28
Wysłany: 14 Czerwiec 2008, 11:34   

No niestety skończyło się tak że wszystko mi się schrzaniło i nie odpalają mi się nawet X-y. Na razie dam sobie spokój z PLD i zainstaluje Backtracka 2, który ma je domyślnie zainstalowane. W każdym razie dzięki.
 
 
qwiat 

Distro: PLD 2.0;3.0
Pomógł: 23 razy
Dołączył: 11 Lut 2006
Posty: 367
Wysłany: 19 Czerwiec 2008, 01:18   

lepiej napisz co zrobiłeś i jakie komunikaty widzisz to może coś poradzimy
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group