PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Problem z cupsem po update do cups-1.3.0
Autor Wiadomość
entereczek
[Usunięty]

Wysłany: 4 Wrzesień 2007, 21:23   Problem z cupsem po update do cups-1.3.0

Witam,

Mam problem z nowym cupsem, ponieważ nie znajduje mojej drukarki po USB Okipage 14ex. Normalnie w polu dodawania drukarki miałem do wyboru AppSocket itd. i jednym z nich było własnie "USB#1 Oki cośtam", którego mi teraz brakuje. Nie jestem w 100% pewien czy to wina cupsa, ponieważ zauważyłem, że udev nie ładuje automatycznie lp tylko samo usblp. Nie wiem czy tak powinno być bo nie pamiętam jak to było przed update'm do tej wersji.
Mam zainstalowane takie pakiety:
Kod:
$ rpm -qa | grep cups
libgnomecups-0.2.2-6.athlon
cups-1.3.0-1.athlon
cups-image-lib-1.3.0-1.athlon
gnome-cups-manager-0.31-1.athlon
cups-lib-1.3.0-1.athlon
cups-filter-foomatic-3.0.2-2.athlon
cups-clients-1.3.0-1.athlon
cups-backend-usb-1.3.0-1.athlon

Udev ładuje takie moduły:
Kod:
$ sudo lsmod | grep lp
usblp                  12416  0
usbcore               116872  6 usbhid,usbkbd,usblp,ehci_hcd,ohci_hcd

Kod:
$ echo "test" > /dev/usb/lp0
skutkuje wydrukiem
Próbowałem na siłę załadować moduł lp i po tej operacji mam taki wynik z lsmoda:
Kod:
$ sudo modprobe lp
$ sudo lsmod | grep lp
usblp                  12416  0
lp                      9764  0
parport                31688  2 lp,parport_pc
usbcore               116872  6 usblp,usbhid,usbkbd,ehci_hcd,ohci_hcd

Po wyłączeniu i włączeniu drukarki w dmesgu pojawia mi się coś takiego:
Kod:
usb 1-2: new full speed USB device using ohci_hcd and address 7
Device driver usbdev1.7_ep00 lacks bus and class support for being resumed.
usb 1-2: configuration #1 chosen from 1 choice
Device driver usbdev1.7_ep01 lacks bus and class support for being resumed.
Device driver usbdev1.7_ep82 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x06BC pid 0x000B

Spotkał się ktoś z czymś podobnym wcześniej?
Z góry dziękuję za pomoc
Pozdrawiam
Entereczek

Update: Dorzucam jeszcze pare informacji diagnostycznych
Kod:
$ sudo uname -a
Linux pingwinek 2.6.21.3-1 #1 SMP Mon Jun 4 10:41:09 UTC 2007 i686 AMD_Athlon(tm)_64_X2_Dual_Core_Processor_4000+ PLD Linux
$ sudo lsusb
Bus 006 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 002 Device 003: ID 046d:c30e Logitech, Inc.
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 008: ID 06bc:000b Oki Data Corp.
Bus 001 Device 001: ID 0000:0000 
$ sudo cat /proc/bus/usb/devices | tail -n 7
T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  8 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=06bc ProdID=000b Rev= 0.00
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group