PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
problem z konfiguracją X.org (X11)
Autor Wiadomość
e-Łukasz
[Usunięty]

Wysłany: 3 Wrzesień 2005, 22:37   problem z konfiguracją X.org (X11)

Witam
Mam problem, mianowicie zainstalowalem i skonfigurowałem serwer protokołu X11 tak jak zostało to napisane na tej stronie http://pl.docs.pld-linux.org/x_wstep.html
jednak po wpisaniu komendy
#X
wyskakuje mi kolorowe okienko gdzie sa informacje o czestotliwosci monitora i odliczanie 20 sek. po czym wlacza sie "power management":|
# ctrl + alt + backspace (wychodze)
i pisze jakie byly bledy
(EE) LoadModule: Module keybord does not have a keybordModuleData data object
(EE) Failed to load module "keybord" (invalid module, 0)
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdr.a is unresolved
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdr.a is unresolved
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)

Widze ze nie wykrywa sterownikow Nvidii ale zrobiłem wszystko co napiasli na tamtej stronie i wszystko przebieglo pomyslnie. Nie wiem co robic, pomozcie mi to naprawic. Dziękuję

[ Added: 2005-09-03, 23:38 ]
sorry zły link podałem....http://pl.docs.pld-linux.org/x_xserver.html
ten jest dobry i zrobiłem co było tam napisane.
 
 
pit 


Pomógł: 8 razy
Dołączył: 27 Lip 2005
Posty: 136
Skąd: Ostrów Wielkopolski
Wysłany: 4 Wrzesień 2005, 00:00   

potrzeba jeszcze doinstalować pakiet zawierajacy moduł do obsługi karty graficznej - jak wyżej widzę karta nvidii wiec jeśli masz aktualne jajko z repo to pewnie potrzeba Ci
Kod:
poldek -i kernel-video-nvidia
no i w /etc/xorg.conf proponuję wpisać kbd jako sterownik klawiatury... chyba tyle starczy :)
no i jeszcze w instrukcji nie widzę nic o tym żeby doinstalować jeszcze pakiet X11-driver-nvidia - też sie przyda :-b
_________________
:-(
 
 
 
Chavez 
asylus.pl


Dołączył: 06 Lip 2005
Posty: 51
Skąd: Szczecin
Wysłany: 4 Wrzesień 2005, 11:19   

Cytat:
(EE) LoadModule: Module keybord does not have a keybordModuleData data object
(EE) Failed to load module "keybord" (invalid module, 0)


A to chyba znaczym, ze klawiatury nie wykryl, no nie? Ja w xorg.conf klawiature mam na module
Kod:
Driver "kbd"
. Moze pomoze.
_________________
"Dobre piwo jest jak dobry system operacyjny: Ty już padniesz a ono ciągle działa!"
http://chavez.asylus.pl - Trochę wolniej...
 
 
 
e-Łukasz
[Usunięty]

Wysłany: 4 Wrzesień 2005, 14:17   

Wiem wiem ze trzeba zainstalowac X11-driver-nvidia i kernel-video-nvidia.
Zrobiłem od początku wszystko to co tam jest i zauważyłem że wtedy nie zamieniłem w tym pliku /etc/X11/xorg.conf w sekcji device driver z nv na nvidia. No ale teraz już zrobiłem wszystko dobrze i wpisałem kbd tak jak mówiliście. Jednak dalej nie może znależć NVidii
modprobe: Can not locate module nvidia
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): ***Aborting***
(EE) Sreen(s) found, but none have a usable configuration

Fatal server error:
no screens found

Nie wiem co mam robić. Na 100% wszystko zrobiłem dobrze. Proszę o pomoc...
 
 
pit 


Pomógł: 8 razy
Dołączył: 27 Lip 2005
Posty: 136
Skąd: Ostrów Wielkopolski
Wysłany: 4 Wrzesień 2005, 22:24   

a bez X'ów
Kod:
# modprobe nvidia
działa?
_________________
:-(
 
 
 
evil_core 
hackin'newbie...


Pomógł: 9 razy
Dołączył: 10 Lip 2005
Posty: 178
Skąd: Kraków
Wysłany: 5 Wrzesień 2005, 15:08   

Sprawdz czy napewno zainstalowales modul so swojej wersji kernela.
Sprawdz czy nie zaladowales jakis modulow ktore moga kolidowac z modulem nvidii (np rivafb).

Ja z nvidia mam raczej dobre dosiadczenia, ale ostatnio bratu radeona 9600pro konfigurowalem., i nie chcialo dzialac z via-agp, i musialem zaladowac ati-agp :/ // nie znam sie na ati, i nie wiem czy to jest normalne
 
 
e-Łukasz
[Usunięty]

Wysłany: 5 Wrzesień 2005, 20:33   

Przepraszam, że nie odpisywałem, ale provider internetu się wyłożył i nie miałem:|
Więc spróbowałem #modprobe nvidia
Can't find module nvidia

a co do koligowania ze sobą pakietów to rzeczwiście. Z pośród podanych w tym poradniku pakietów które trzeba zainstalować jest X11-OpenGL-core i kiedy go instaluję pokazuje, że jakiś tam plik jest dostępny w trzech pakietach.
a) OpenGL-Libg -coś takiego nie pamiętam
b) X11-driver-(nie pamiętam dalej ale napewno nie to)
c) X11-driver-nvidia

I pyta który chcę zainstalować. Jak wybieram nvidii to wyskakuje błąd a jak wybiorę ten OpenGL to normalnie się instaluje.

Kiedy przechodzę do instalacji X11-driver-nvidia instaluje go ale usuwa OpenGL więc zainstalowałem ten pakiet X11-OpenGL-core z opcją "just-install". To chyba najrozsądniejszy sposób.
Oczywiście próbowałem najpierw bez tego OpenGL-core oraz z nim <ale z tą opcją a)>

Jak sprawdzić czy dla swojego kernela zainstalowałem sterowniki? Poldek chyba automatycznie ma już po instalacji systemu dla której platformy instalować pakiety.
 
 
Chavez 
asylus.pl


Dołączył: 06 Lip 2005
Posty: 51
Skąd: Szczecin
Wysłany: 6 Wrzesień 2005, 10:30   

Kod:
X11-driver-nvidia-1.0.7174-2
kernel-video-nvidia-1.0.7174-2@2.6.11.10_6

1.0.7174-2 to numer sterownikow
2.6.11.10_6 to wersja kernela na ktora sa te stery
_________________
"Dobre piwo jest jak dobry system operacyjny: Ty już padniesz a ono ciągle działa!"
http://chavez.asylus.pl - Trochę wolniej...
 
 
 
e-Łukasz
[Usunięty]

Wysłany: 6 Wrzesień 2005, 18:40   

instalowalem dla swojego jadra i swojej platformy athlon ...ale przeciez nie dziala:/ i wez tu sie nie wkurzaj:)
 
 
littleb
Gość
Wysłany: 6 Wrzesień 2005, 18:55   

Ej no skoro nvidia to nie OpenGL-core po co ci to ?
odinstaluj i sama nvidie. Poldek to takie cudo ze sam powinien dociagnac co potrzebuje.
Jezeli nie bedzie dzialalo prawdopodobnie bedziesz musial zbudowac inna nvidie na builderze. Ja tak mialem
 
 
raikou 
lim IQ->0 IQ = 0


Pomógł: 25 razy
Dołączył: 06 Lip 2005
Posty: 295
Skąd: Warszawa
Wysłany: 6 Wrzesień 2005, 21:14   

Pozumiem że teraz masz OpenGL-*. W przypadku radeona (sterownik ati, firegl) kolizja zachodziła w pakiecie X11-OpenGL-libGL (bo libgl.so jest w obu paczkach). Najprawdopodobniej kolizja jest w tym samym miejscu. Sugeruję więc zrobić:
Kod:
#poldek -e --nodeps --nofollow X11-OpenGL-libGL
#poldek -i X11-driver-nvidia

A następnie ponownie skonfigurować X pod Nvidie i odpalić. Jak nadal krzyczy że X11-driver-nvidia z czymś koliduje to albo wywalić blokujące pakiety albo dać --force.
_________________
Humans cannot create from nothingness, humans cannot accomplish anything without holding on to something, humans are not gods.
 
 
littleb
Gość
Wysłany: 6 Wrzesień 2005, 23:02   

raikou Byzydura
 
 
evil_core 
hackin'newbie...


Pomógł: 9 razy
Dołączył: 10 Lip 2005
Posty: 178
Skąd: Kraków
Wysłany: 18 Wrzesień 2005, 02:30   

Ja tez mialem konflikty poyzszych pakietow..... Pozatym ostatnio byly zmiany w sterowmikach i te nowsze nvidi nie obsluguje niczego starszego od geforce'a2 (jego tez wlaczajac) dla rivytrnt2 - geforce2 ma byc pakiet -legacy

Po drugie jezeli wywala cannot find module, to znaczy ze nie zainstalowales modulu do jadra, a nie ze koliduje z innym modulem :/
 
 
pit 


Pomógł: 8 razy
Dołączył: 27 Lip 2005
Posty: 136
Skąd: Ostrów Wielkopolski
Wysłany: 18 Wrzesień 2005, 09:06   

evil_core napisał/a:
Pozatym ostatnio byly zmiany w sterowmikach i te nowsze nvidi nie obsluguje niczego starszego od geforce'a2 (jego tez wlaczajac) dla rivytrnt2 - geforce2 ma byc pakiet -legacy

DObrze wiedzieć, pewnie bym się lada moment denerwował po _którejś_ aktualizacji... mam geforce'a 2 i nie mam pakietu -legacy, nawet w repo żadnym i działa u mnie wszystko (tak mi się wydaje) - od kiedy taka zmiana ma być, wiadomo?
_________________
:-(
 
 
 
evil_core 
hackin'newbie...


Pomógł: 9 razy
Dołączył: 10 Lip 2005
Posty: 178
Skąd: Kraków
Wysłany: 18 Wrzesień 2005, 15:49   

w repo mize jeszcze nie ma, ale od czego jest cvs i spece :P
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group