PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
[solved]gnome-shell - duże zużycie pamięci
Autor Wiadomość
azbael
[Usunięty]

Wysłany: 9 Czerwiec 2011, 15:23   [solved]gnome-shell - duże zużycie pamięci

Chwilę po zalogowaniu się do gnome 3, rośnie zużycie pamięci przez gnome-shell i nie za bardzo da się pracować.
Gdy zużycie pamięci wynosi około 20% to przeładowuje środowisko aby się całkiem nie wywaliło.
Wykorzystanie pamięci oczywiście spada ale zaraz znowu zaczyna rosnąć. I tak w kółko.
W krytycznym momencie gnome-shell zabierał około 80% pamięci, ale wtedy już nic się nie dało zrobić, tylko twardy reset.

Spotkał się może ktoś z takim problemem?
Ostatnio zmieniony przez azbael 12 Sierpień 2011, 11:13, w całości zmieniany 1 raz  
 
 
azbael
[Usunięty]

Wysłany: 10 Czerwiec 2011, 19:31   

A czy udało się może komuś uruchomić gnome3 na Radeon Mobility X1600 + KMS?
U mnie się wywala po zalogowaniu, a w logach dostaję coś takiego:
Kod:
Jun 10 18:17:29 loptok kernel: [   62.404617] gnome-shell.bin[3388]: segfault at 0 ip    (nil) sp bf85021c error 4 in gnome-shell.bin[8048000+3000]
Jun 10 18:17:30 loptok kernel: [   63.503684] gnome-shell.bin[3443]: segfault at 0 ip    (nil) sp bf8d821c error 4 in gnome-shell.bin[8048000+3000]
Jun 10 18:17:33 loptok kernel: [   66.274084] gnome-settings-[3356]: segfault at b3f81767 ip b3f81767 sp bff9e90c error 4 in libpixbufloader-svg.so[b3fe3000+1000]
 
 
azbael
[Usunięty]

Wysłany: 12 Sierpień 2011, 11:13   

Rozwiązałem to tak:
1. Zainstalowałem kernel wersji kernel-laptop-2.6.39.2-1. Na jądrze w wersji kernel-2.6.38.8-1.i686 nie chciało działać.
2. Przebudowałem Mese w wersji 7.10.3 z opcją "--with gallium". Mesa w najnowszej wersji nie chciała się zbudować.
Kod:
glxinfo | grep OpenGL
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV530
OpenGL version string: 2.1 Mesa 7.10.3
OpenGL shading language version string: 1.20
OpenGL extensions:

3. Do pliku /etc/modprobe.d/modprobe.conf dodałem wpis:
Kod:
options radeon modeset=1

4. W pliku /boot/grub/menu.lst do linii:
Kod:
kernel /vmlinuz-laptop root=/dev/sda3 ro

dodałem:
Kod:
radeon.modeset=1

5. Do pliku /etc/sysconfig/geninitrd dodałem:
Kod:
BASICMODULES="intel_agp"
FBMODULE="radeon"
i przebudowałem geninitrd.

Teraz wszystko działa jak powinno oprócz hibernacji :)
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group