PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

Th - mencoder - nagrywanie z tv - problem z dźwiękiem

prism - 3 Wrzesień 2007, 13:46
Temat postu: mencoder - nagrywanie z tv - problem z dźwiękiem
Próbuję nagrać sobie wideo z TV. Odtwarzanie działa bez problemu.

Do nagrania chcę użyć mencodera. Problem w tym, że wynikowe nagranie nie zawiera dźwięku - chociaż dźwięk słychać w trakcie nagrywania.

Do nagrania 10-sekundowej próbki "do testów" używam takiego polecenia:
Kod:
mencoder -tv driver=v4l2:input=0:norm=pal:width=640:height=480:freq=199.75:alsa:audiorate=32000:adevice=hw.0,0:amode=1:forceaudio -ffourcc XVID -ovc lavc -lavcopts vcodec=mpeg4:mbd=2:vbitrate=1200 -oac mp3lame -lameopts cbr:br=96 -vf pp=lb -endpos 10 -o test.avi tv://


Nie potrafię dojść do tego, dlaczego nie nagrywa dźwięku. Capture na line-in mam "zaznaczone", suwak głośności na jakieś 70%.

Karta TV jest na saa7134, dźwięk uzyskuję spinająć kartę TV z wejściem line-in dźwiękówki. Prawdopodobnie dałoby się użyć również saa7134-alsa do pobrania dźwięku prosto z karty TV, ale podczas wcześniejszego eksperymentowania miałem z tym problemy i się poddałem.

Czy ktoś potrafi pomóc?

prism - 3 Wrzesień 2007, 15:38

Zacząłem intensywniej googlować i okazuje się, że nie tylko ja mam z tym problem. Znalazłem informację, że oprócz wejścia liniowego, trzeba jeszcze mieć zaznaczone ogólnie Capture do nagrywania, sprawdzę dzisiaj czy to pomoże.
prism - 3 Wrzesień 2007, 18:35

Powyższa sugestia okazała się być prawdziwa - teraz nagrywa się z dźwiękiem.
KrystianT - 3 Wrzesień 2007, 19:48

Tak przy okazji - w prawym górnym rogu każdego posta są przyciski - jeden z nich to "edit" - nie musiałeś pisać trzech wiadomości...

Powered by phpBB modified by Przemo © 2003 phpBB Group