PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

Th - X.org, paru pakietów nie widzi

yellowfox - 12 Sierpień 2007, 13:42
Temat postu: X.org, paru pakietów nie widzi
Witam, niedawno udało mi sie zainstalować PLD z rescueCD, teraz próbuje skonfigurować Serwer Xów ale poldek ma problem z dociągnięciem paru pakietów między innymi

Kod:

X11-fonts-100dpi-ISO8859-2
X11-common
X11-fonts-75dpi-ISO8859-2


w dodatku kiedy chcialem sciagac przez poldka

Kod:

poldek -i ping

wywala i pisze ze nie zna pakietu

O co biega ?

svl - 12 Sierpień 2007, 13:48

yellowfox napisał/a:
poldek ma problem z dociągnięciem paru pakietów

podaj dokładnie jakie błędy się pojawiają
yellowfox napisał/a:
wywala i pisze ze nie zna pakietu

Kod:
poldek:/all-avail> search ping
Przeszukiwanie pakietów..........................................zrobione.
2 package(s) found:
iputils-ping-ss021109-4
iputils-ping-ss021109-5

yellowfox - 12 Sierpień 2007, 14:09

Z ping sobie w^3asnie poradzilem, zmylil mnie czerwony kolor ktory wyskakuje i nie zauwazylem ze cos znalazl, natomiast nie wiem jakie pakiety trzeba zainstalowac dla x servera, znalazlem przez search wprawdzie fonty 75dpi i 100 ale bez zadnej normy iso jak pisalo w dokumentacji PLD przy konfiguracji X`ow

a i kompletnie nie widzi pakietu X11-common, jest potrzebny ?

Bardzo prosze o podanie mi jakie pakiety sa potrzebne do uruchomienia Serwera X`ow ktore sa dostepne pod repo th

svl - 12 Sierpień 2007, 14:15

yellowfox napisał/a:
ktore sa dostepne pod repo th

no i tu się wprawa wyjaśniła, dokumentacja dotyczy AC i starszych wersji X, w TH są mudularne X i paczki zaczynają się od xorg-coś-tam, sprawdź ten wątek http://forum.pld-linux.or...der=asc&start=0 albo zbuduj sobie http://cvs.pld-linux.org/...ckage-xorg.spec

yellowfox - 12 Sierpień 2007, 15:31

Gdyby to jeszcze było prostsze :sad: Jestem początkującym userem PLD, mogę prosić jakąś dokumentacje jak korzystać z tych speców?

Wątek przeglądałem ale nie znalazłem jasnych info co jest potrzebne do bezproblemowego zainstalowania Xorga w dodatku nie bardzo było wiadomo czy tam mowa jeszcze o ac czy th bo każdy o innym mówił :neutral:

KrystianT - 12 Sierpień 2007, 17:06

yellowfox napisał/a:
nie znalazłem jasnych info co jest potrzebne do bezproblemowego zainstalowania Xorga
W repozytorium są pakiety ułatwiające instalację (a właściwie przejście z X11 na) xorg.
Kod:
poldek:/all-avail> desc X11-7.0.0-1.i686
Package:        X11-7.0.0-1.i686
Summary:        Pakiet X11 ułatwiający przejście z monolitycznego X11 na modularne xorg
[...]
Package:        X11-Xserver-7.0.0-1.i686
Summary:        Pakiet Xserver ułatwiający przejście z monolitycznego X11 na modularne xorg
[...]
poldek:/all-avail> ls X11*7.0*
[...]
To są pakiety bez plików, tylko z requires żeby pociągnąć odpowiednie pakiety z xorg. Możesz przez desc -r zobaczyć co za sobą pociągną...

yellowfox - 12 Sierpień 2007, 17:14

czyli z powodzeniem mogę skorzystać ze starych instrukcji

Cytat:


Na początku, korzystając z programu poldek instalujemy pakiety potrzebne do uruchomienia serwera X11 :

install X11 X11-modules X11-fonts-100dpi-ISO8859-2 X11-setup \
X11-imake X11-libs X11-Xserver X11-OpenGL-libs X11-fonts \
X11-xfs X11-common X11-fonts-base X11-xauth X11-fonts \
X11-fonts-75dpi-ISO8859-2 X11-OpenGL-core X11-fonts-100dpi \
X11-fonts-ISO8859-2 X11-sessreg xinitrc-ng


żeby znaleźć te ułatwiające przejscie na xorg pakiety ?

KrystianT - 12 Sierpień 2007, 17:38

W zasadzie tak, tylko zwróć uwagę na fonty (brak niektórych na podanej liście) - powinny wystarczyć:
X11-fonts-7.0.0-1.i686
X11-fonts-ISO8859-2-7.0.0-1.i686
X11-fonts-100dpi-7.0.0-1.i686
X11-fonts-base-7.0.0-1.i686

yellowfox - 12 Sierpień 2007, 17:49

a co z X11-common ? tego w ogóle nie znajduje
KrystianT - 12 Sierpień 2007, 18:31

yellowfox napisał/a:
a co z X11-common

Zainstaluj X11-libs-7.0.0-1.i686
Kod:
poldek:/all-avail> desc -C X11-libs-7.0.0-1.i686
Package:        X11-libs-7.0.0-1.i686
Provides:       X11-DPS, XFree86-libs = 1:7.0.0-1
Requires:       xorg-app-bitmap, xorg-app-xditview, xorg-app-xmh, xorg-data-xbitmaps
Requires(rpm):  rpmlib(PayloadIsLzma) <= 4.4.6-1
Obsoletes:      X11-DPS, X11-common, XFree86-DPS, XFree86-common

X11-libs-7.0.0-1.i686 zastępuje X11-common

Bardzo ładnie można to wszystko wyszukać poldkiem
Kod:
poldek:/all-avail> search -o X11-common
1 package(s) found:
X11-libs-7.0.0-1.i686
poldek:/all-avail> search -o X11-fonts-100dpi-ISO8859-2
1 package(s) found:
X11-fonts-100dpi-7.0.0-1.i686


Powered by phpBB modified by Przemo © 2003 phpBB Group