PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

Th - [th]problemy z ruby w KDE

jefe - 18 Maj 2007, 21:10
Temat postu: [th]problemy z ruby w KDE
Witam, ilekroć chcę zainstalowac kdebindings-ruby-* wyskakuje mi taki błąd:
błąd: kdebindings-ruby-kde-3.5.6-2: nie znaleziono wymaganego /usr/lib/ruby/site_ruby/1.8/KDE
kdebindings-ruby-qt-3.5.6-2 zostanie zastąpiony przez kdebindings-ruby-qt-3.5.6-2
błąd: kdebindings-ruby-qt-3.5.6-2: nie znaleziono wymaganego /usr/lib/ruby/site_ruby/1.8/Qt

daję ls i:
ls /usr/lib/ruby/site_ruby/1.8/
i686-linux KDE Korundum.rb Qt Qt.rb
no cóż, wobec tego instaluję przez --nodeps, idzie, ok. Problem w tym, ze każdy skrytp w Amaroku, który zainstaluję rpuje się, bo ma problemy z brakiem ruby, np:
Wiki-Lyrics:
Sorry...
You need one of QtRuby, RubyGTK or TkRuby to run this program

Leos Lyrics:
Skrypt "Leos" zakończył działanie z kodem błędu: 1
/home/pawel/.kde/share/apps/amarok/scripts/lyrics_leos/lyrics_leos.rb:94: too short multibyte code string: /[\x00-\x1f]|[\xc0-\xfd][\x80-\xbf]+/

ruby-1.8.6-2

Kurde, o co mu idzie? Proszę o jakąś poradę.

zalp - 18 Maj 2007, 22:01

Kod:
ruby-tk

?

jefe - 19 Maj 2007, 09:55

Heh, tyle zainstalowałem pakietów ruby-* a ten pominąłem. Dzięki, działają Wiki-Lyrics. A leos-Lyrics dalej sypie tym samym błędem, ale to widać błąd wewnętrzny skryptu, tak informacyjnie.

Powered by phpBB modified by Przemo © 2003 phpBB Group