PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Instalacja X-server
Autor Wiadomość
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 29 Grudzień 2005, 18:57   Instalacja X-server

Wywala mi takie cos:

(EE) GARTInit: Unable to open /dev/agpgart (No such device)
(WW) *** WARNING the legacy keyboard driver "keyboard" is deprecated
(WW) *** and will be removed in the next release of the Xorg server.
(WW) *** Please consider using the the new "kbd" driver for "Keyboard0".

Do tego pierwszego wystarczy stworzyc /dev/agpgart ?? czy sa tam jakies pliki ??
To drugie to terowniki do klawiatury... xD I jeszcze w log-u mam warning z biosem i rozdzielczoscia... Czemu ??
 
 
 
Chavez 
asylus.pl


Dołączył: 06 Lip 2005
Posty: 51
Skąd: Szczecin
Wysłany: 29 Grudzień 2005, 19:22   

w xorg.conf zmien sterowniki klawiatury na kbd
_________________
"Dobre piwo jest jak dobry system operacyjny: Ty już padniesz a ono ciągle działa!"
http://chavez.asylus.pl - Trochę wolniej...
 
 
 
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 29 Grudzień 2005, 19:53   

ok a ten error ?? i sie jeszcze chcialem zapytac jak wpisac moduly do modprobe.conf... ??
 
 
 
karat611
[Usunięty]

Wysłany: 29 Grudzień 2005, 20:05   

w pliku /etc/modprobe.conf wpisz
alias do czego ma być np eth(0,1,2,...) i nazwę modułu
Powodzenia!! :lol:
 
 
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 29 Grudzień 2005, 20:31   

No ale mi chodzi wlasnie o to "do czego ma byc" skad ja mam wiedziec jak wpisac grafike dzwiek mysz czy cokolwiek innego...
 
 
 
darede 
>:)


Pomógł: 16 razy
Dołączył: 19 Lip 2005
Posty: 407
Skąd: Głuchołazy/Wrocław
Wysłany: 29 Grudzień 2005, 21:27   

Doom napisał/a:
(EE) GARTInit: Unable to open /dev/agpgart (No such device)


zaladuj modul agpgart

Kod:
# modprobe agpgart
_________________
http://darede.jogger.pl
 
 
 
kermit 

Dołączył: 25 Gru 2005
Posty: 1
Skąd: Krosno
Wysłany: 29 Grudzień 2005, 21:33   

Doom napisał/a:
No ale mi chodzi wlasnie o to "do czego ma byc" skad ja mam wiedziec jak wpisac grafike dzwiek mysz czy cokolwiek innego...


najpierw
# lspci

potem postaraj się załadować moduły do AGP odpowiednie do twojej płyty głównej.

na koniec
X -configure

I wykonać to, co pisze w ostatniej linijce.
 
 
 
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 29 Grudzień 2005, 23:05   

spieprzylem caly plik xorg.conf co mam zrobic ?? :D Moge usunac zawartosc czy musze hmmm wywalac poszczegolne rzeczy ??
 
 
 
darede 
>:)


Pomógł: 16 razy
Dołączył: 19 Lip 2005
Posty: 407
Skąd: Głuchołazy/Wrocław
Wysłany: 29 Grudzień 2005, 23:08   

Doom napisał/a:
spieprzylem caly plik xorg.conf


tzn co zrobiles?
_________________
http://darede.jogger.pl
 
 
 
spider 
Administrator
Developer


Pomógł: 39 razy
Dołączył: 03 Lip 2005
Posty: 1144
Skąd: Szczecin
Wysłany: 29 Grudzień 2005, 23:13   

Doom napisał/a:
spieprzylem caly plik xorg.conf co mam zrobic ??

wygeneruj nowy
_________________
Zanim zadasz pytanie: przeczytaj
Surfuj bez obaw!praca
 
 
pooh 


Pomógł: 151 razy
Dołączył: 06 Lip 2005
Posty: 1340
Skąd: Wrocław
Wysłany: 29 Grudzień 2005, 23:16   

Doom napisał/a:
spieprzylem caly plik xorg.conf co mam zrobic ??

Odtwórz z kopii zapasowej. Masz kopię, prawda? ;-)

"Gołą" wersję pliku możesz wyciągnąć z paczki X11-Xserver (sciągasz plik .rpm, odpalasz mc, wchodzisz do pliku .rpm, znajdujesz plik, kopiujesz go we właściwe miejsce).
_________________
Pooh
 
 
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 29 Grudzień 2005, 23:41   

Ok dzieki :)
 
 
 
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 30 Grudzień 2005, 16:50   

Teraz jak daje X to wywala mi:
Kod:

Fatal server error:
no screens found

Pozniej jest
Kod:
Please consult the The X.Org Foundation support
    at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(WW) xf86CloseConsole: VT_GETSTATE failed: Bad file descriptor
(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor


Jak chcecie moge wam pokazac Xorg.conf (to jest czesc log-a)
 
 
 
darede 
>:)


Pomógł: 16 razy
Dołączył: 19 Lip 2005
Posty: 407
Skąd: Głuchołazy/Wrocław
Wysłany: 30 Grudzień 2005, 17:03   

no to pokaz :)
_________________
http://darede.jogger.pl
 
 
 
Doom 

Dołączył: 25 Gru 2005
Posty: 211
Skąd: Legionowo
Wysłany: 30 Grudzień 2005, 17:11   

Polowa pewnie jest zle...
Kod:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath      "/usr/X11R6/lib/X11/rgb"
#    ModulePath   "/usr/X11R6/lib/modules"
#    FontPath     "/usr/share/fonts/misc/"
#    FontPath     "/usr/share/fonts/TTF/"
#    FontPath     "/usr/share/fonts/Type1/"
#    FontPath     "/usr/share/fonts/CID/"
#    FontPath     "/usr/share/fonts/75dpi/"
#    FontPath     "/usr/share/fonts/100dpi/"
    FontPath    "unix/:7100"
EndSection

Section "Module"
    Load  "extmod"
    Load  "dbe"
    Load  "dri"
    Load  "record"
    Load  "xtrap"
    Load  "glx"
    Load  "freetype"
    Load  "type1"
EndSection

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option        "Protocol" "ImPS/2"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
    Option "Device"     "/dev/input/mice"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Hi"
    ModelName    "S570"
    HorizSync   31.5 - 150
    VertRefresh 65 - 85
    Option "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "VGAClocks"              # [<bool>]
        #Option     "KGAUniversal"           # [<bool>]
    Identifier  "Card0"
    Driver      "i810"
    VendorName  "Intel Corporation"
    BoardName   "82915G/GV/910GL Express Chipset Family Graphics Controller"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
        Virtual    1024 768
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
        Virtual    1024 768
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
        Virtual    1024 768
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
        Virtual    1024 768
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Virtual    1024 768
    EndSubSection
EndSection
 
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group