PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
upgrade starszej wersji PLD
Autor Wiadomość
kermu 

Dołączył: 12 Kwi 2014
Posty: 6
Wysłany: 9 Marzec 2015, 21:41   upgrade starszej wersji PLD

Przy próbie upgrade kernela

poldek:/all-avail> install kernel-3.4-3.4.106-3.i686
Processing dependencies...
kernel-3.4-3.4.106-3.i686 marks kmod-19-1.i686 (cap kmod >= 12-2)
module-init-tools-3.16-2.i686 obsoleted by kmod-19-1.i686
kmod-19-1.i686 marks glibc-2.21-1.i686 (cap libc.so.6(GLIBC_2.17))
glibc-2.15-6.i686 obsoleted by glibc-2.21-1.i686
greedy upgrade iconv-2.15-6.i686 to 2.21-1.i686 (unresolved glibc = 6:2.15-6)
iconv-2.15-6.i686 obsoleted by iconv-2.21-1.i686
greedy upgrade glibc-localedb-all-2.15-6.i686 to 2.21-1.i686 (unresolved iconv = 6:2.15-6)
glibc-localedb-all-2.15-6.i686 obsoleted by glibc-localedb-all-2.21-1.i686
greedy upgrade glibc-libcrypt-2.15-6.i686 to 2.21-1.i686 (unresolved glibc = 6:2.15-6)
glibc-libcrypt-2.15-6.i686 obsoleted by glibc-libcrypt-2.21-1.i686
greedy upgrade glibc-misc-2.15-6.i686 to 2.21-1.i686 (unresolved glibc = 6:2.15-6)
glibc-misc-2.15-6.i686 obsoleted by glibc-misc-2.21-1.i686
glibc-2.21-1.i686 marks ldconfig-2.21-1.i686 (cap ldconfig = 6:2.21-1)
ldconfig-2.15-6.i686 obsoleted by ldconfig-2.21-1.i686
error: glibc-2.21-1.i686: req uname(release) >= 2.6.32 not found
error: kmod-19-1.i686: req libc.so.6(GLIBC_2.2) not found
error: kmod-19-1.i686: req libc.so.6(GLIBC_2.2.3) not found
error: kmod-19-1.i686: req libc.so.6(GLIBC_2.3) not found
error: kmod-19-1.i686: req libc.so.6(GLIBC_2.3.4) not found
error: kmod-19-1.i686: req libc.so.6(GLIBC_2.4) not found
error: kmod-19-1.i686: req libc.so.6(GLIBC_2.8) not found
kmod-19-1.i686 marks xz-libs-5.2.0-1.i686 (cap liblzma.so.5)
xz-libs-4.999.8-0.beta.1.i686 obsoleted by xz-libs-5.2.0-1.i686
greedy upgrade xz-4.999.8-0.beta.1.i686 to 5.2.0-1.i686 (unresolved xz-libs = 1:4.999.8-0.beta.1)
xz-4.999.8-0.beta.1.i686 obsoleted by xz-5.2.0-1.i686
error: xz-5.2.0-1.i686: req libc.so.6 not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.0) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.1) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.17) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.2) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.3) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.3.3) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.3.4) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.4) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.6) not found
error: xz-5.2.0-1.i686: req libc.so.6(GLIBC_2.7) not found
error: xz-5.2.0-1.i686: req libpthread.so.0 not found
error: xz-5.2.0-1.i686: req libpthread.so.0(GLIBC_2.0) not found
error: xz-5.2.0-1.i686: req libpthread.so.0(GLIBC_2.2) not found
error: xz-5.2.0-1.i686: req rtld(GNU_HASH) not found
error: xz-libs-5.2.0-1.i686: req libc.so.6 not found
error: xz-libs-5.2.0-1.i686: req libc.so.6(GLIBC_2.0) not found
error: xz-libs-5.2.0-1.i686: req libc.so.6(GLIBC_2.1.3) not found
error: xz-libs-5.2.0-1.i686: req libc.so.6(GLIBC_2.17) not found
error: xz-libs-5.2.0-1.i686: req libc.so.6(GLIBC_2.4) not found
error: xz-libs-5.2.0-1.i686: req libpthread.so.0 not found
error: xz-libs-5.2.0-1.i686: req libpthread.so.0(GLIBC_2.0) not found
error: xz-libs-5.2.0-1.i686: req libpthread.so.0(GLIBC_2.1) not found
error: xz-libs-5.2.0-1.i686: req libpthread.so.0(GLIBC_2.3.2) not found
error: xz-libs-5.2.0-1.i686: req libpthread.so.0(GLIBC_2.3.3) not found
error: xz-libs-5.2.0-1.i686: req rtld(GNU_HASH) not found
error: kmod-19-1.i686: req liblzma.so.5(XZ_5.0) not found
error: kmod-19-1.i686: req libpthread.so.0 not found
error: kmod-19-1.i686: req libpthread.so.0(GLIBC_2.0) not found
error: kmod-19-1.i686: req libpthread.so.0(GLIBC_2.2) not found
error: kmod-19-1.i686: req rtld(GNU_HASH) not found
error: kernel-3.4-3.4.106-3.i686: req kmod >= 12-2 not found
There are 10 packages to install (9 marked by dependencies), 9 to remove:
I kernel-3.4-3.4.106-3.i686
D glibc-2.21-1.i686 glibc-libcrypt-2.21-1.i686 glibc-localedb-all-2.21-1.i686 glibc-misc-2.21-1.i686 iconv-2.21-1.i686 kmod-19-1.i686 ldconfig-2.21-1.i686
D xz-5.2.0-1.i686 xz-libs-5.2.0-1.i686
R glibc-2.15-6.i686 glibc-libcrypt-2.15-6.i686 glibc-localedb-all-2.15-6.i686 glibc-misc-2.15-6.i686 iconv-2.15-6.i686 ldconfig-2.15-6.i686
R module-init-tools-3.16-2.i686 xz-4.999.8-0.beta.1.i686 xz-libs-4.999.8-0.beta.1.i686

Jak sobie poradzić z tym ?
System dość leciwy jest
Linux K-SER14-VM107-lmsgit 2.6.28.10-3 #1 SMP Wed Jul 22 01:48:30 CEST 2009 i686 Common_KVM_processor PLD Linux
 
 
 
bas 


Distro: PLD 2.0;3.0
Pomógł: 199 razy
Dołączył: 06 Lip 2005
Posty: 2305
Skąd: Łódź
Wysłany: 25 Marzec 2015, 11:16   

Spróbuj najpierw z palca zainstalować najnowszego glibc'a.

Pozdrawiam BAS
 
 
 
kermu 

Dołączył: 12 Kwi 2014
Posty: 6
Wysłany: 28 Marzec 2015, 09:49   

bas napisał/a:
Spróbuj najpierw z palca zainstalować najnowszego glibc'a.

Pozdrawiam BAS


Poradziłem sobie podnosząc najpierw kernela do 2.6.38. Potem poszedł upgr. glibc-a.

Pozdrawiam
 
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group