PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Ipla - działa komuś?
Autor Wiadomość
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 5 Październik 2010, 16:04   Ipla - działa komuś?

Prosze o przepis jak uruchomić iplę pod PLD. Testuję, jak widać, Ubuntu, poszło od ręki. Pod PLD próbowałem wg sposobu z adobeair sdk (wg opracowania dla Gentoo) ale w najlepszym razie dostaję czarny ekran. Działa to komuś i może się pochwalić jak do tego doszedł, najlepiej krok po kroku?
 
 
rkd 

Pomógł: 3 razy
Dołączył: 07 Lut 2009
Posty: 21
Wysłany: 6 Październik 2010, 17:03   

Zakładam, że AIR SDK jest zainstalowane w /opt/
wget http://ipla.pl/templates/ipla/assets/iplalite.air
mkdir IPLA
unzip -d IPLA iplalite.air
kwalletd
/opt/SDK/bin/adl -nodebug ~/IPLA/META-INF/AIR/application.xml ~/IPLA/

Na i686 th z KDE
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 6 Październik 2010, 22:12   

No to już jakiś postęp, dziękuję. Jeden załatwiony (koleś), a drugi, czyli ja, siedzi na Gnomie. Może w tym kierunku też podpowiedź?
 
 
rkd 

Pomógł: 3 razy
Dołączył: 07 Lut 2009
Posty: 21
Wysłany: 7 Październik 2010, 14:14   

W ustawieniach Gnome'a Szyfrowanie, Klucze czy jakoś tak ustawić, żeby pamiętał hasła.

gnome-keyring-daemon

Za pierwszym podejściem:
mv ~/.appdata ~/.appdata.old

/opt/SDK/bin/adl -nodebug ~/IPLA/META-INF/AIR/application.xml ~/IPLA/

Wtedy powinien zapytać o hasło.
Hasło za pierwszym razem jest chyba dowolne.
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 14 Październik 2010, 18:57   

Niestety, nie działa. Dostaję czarne okno i takie komunikaty w konsoli:

I/O warning : failed to load external entity "/etc/opt/Adobe/certificates/AIR/crypt//config.xml"
Unable to parse Document: /etc/opt/Adobe/certificates/AIR/crypt//config.xml.
Error: HTMLLoader failed to initialize
checking for updates
TypeError: Error #1009
no updates
list of all categories parsed in 48ms
 
 
rkd 

Pomógł: 3 razy
Dołączył: 07 Lut 2009
Posty: 21
Wysłany: 30 Grudzień 2010, 22:21   

Wiem o co chodziło.
Potrzebne jest libpng12.
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 21 Styczeń 2011, 16:40   

No właśnie! Ja też o tym zapomniałem, kiedyś identyczny myk potrzebny był także na Archu. Tak nawiasem, ale ta Ipla na PLD zap....ala, włączenie, obsługa menu, już nie tylko wszelkie Ubuntu/Fedory odpadają ale i Windows leży. Jedno mnie tylko męczy, że po chwili grania materiału następuje zwiecha obrazu zaś dźwięk leci.
W konsoli dostaję tylko to:

[pawel@pldmachine ~]$ /opt/AIR-SDK/bin/adl -nodebug ~/IPLA/META-INF/AIR/application.xml ~/IPLA/
I/O warning : failed to load external entity "/etc/opt/Adobe/certificates/AIR/crypt//config.xml"
Unable to parse Document: /etc/opt/Adobe/certificates/AIR/crypt//config.xml.
checking for updates
no updates
list of all categories parsed in 52ms
HTTPOffsetSource
HTTPSource
 
 
fi9o 

Dołączył: 15 Lut 2008
Posty: 174
Skąd: Jędrzejów
Wysłany: 13 Luty 2011, 11:01   

Znajomy Nowo-Zelandczyk ktoremu pokazalem iple postanowil napisac jakis prosty programik do pobierania filmow z niej.

http://sourceforge.net/projects/sciagnijziply/ kazdy blad jezykowy jaki tam wystapi jest powodem tego, ze chlopak uczy sie jezyka polskiego caly czas, a nasz jezyk nie jest najprostszy. Ktos moze to testnac i jak cos poprosic o umieszczenie w cvs.
_________________
<a href="http://fotoo.pl/zdjecia/files/2009-02/ac3f0a0d.gif" rel="nofollow" target="_blank" class="postlink">http://fotoo.pl/zdjecia/files/2009-02/ac3f0a0d.gif</a>
 
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 13 Luty 2011, 13:20   

Jak tylko dorwę się do swojego PLDka to od razu przetestuję i dam znać. PS. Nowozelandczyk i język polski? Ciekawa sprawa :shock:
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 18 Luty 2011, 19:32   

Próbuję skompilować ten program, ale dostaję takie info:
$ make
gcc -o szi.exe -I d:\curl\include main.c -lcurl -lxml2 -lxslt
main.c:27:21: fatal error: windows.h: Nie ma takiego pliku ani katalogu
compilation terminated.
make: *** [all] Błąd 1

Poszukałem w poldku co dostarcza windows.h, zainstalowałem mase pakietów, a problem nie zniknął.
 
 
fi9o 

Dołączył: 15 Lut 2008
Posty: 174
Skąd: Jędrzejów
Wysłany: 23 Luty 2011, 12:34   

Bo jesli spojrzec na to to kompilator chce nam zdzialac exe dla windowsa, dam znac dzis wieczorem cos o wersji dla linuksa.
_________________
<a href="http://fotoo.pl/zdjecia/files/2009-02/ac3f0a0d.gif" rel="nofollow" target="_blank" class="postlink">http://fotoo.pl/zdjecia/files/2009-02/ac3f0a0d.gif</a>
 
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 23 Luty 2011, 14:59   

To mnie własnie zdziwiło, no ale ja się nie znam...
 
 
fi9o 

Dołączył: 15 Lut 2008
Posty: 174
Skąd: Jędrzejów
Wysłany: 28 Lipiec 2012, 10:47   

Odgrzejemy ten kotlet.
Instalujemy pythona 2.7(ale pewnie bedziemy go miec)
instalujemy wxpython dla 2.7(nie python-wx czy jakies takie tam)
Pobieramy szi-python.py z http://sourceforge.net/projects/szi-python/files/ nadajemy +x i po uruchomieniu ssiemy z ipli.

Dwie uwagi. niektore z plikow sa z innego z serwera i w formacie mp4, nie dziala na niach progressbar i pobieraja sie dluzej i wolniej. Jakosc pobranych filmow 'dupy nie urywa' ale jest. :)

Pozdrawiam, fi9o.
_________________
<a href="http://fotoo.pl/zdjecia/files/2009-02/ac3f0a0d.gif" rel="nofollow" target="_blank" class="postlink">http://fotoo.pl/zdjecia/files/2009-02/ac3f0a0d.gif</a>
 
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group