PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Problem z RPM
Autor Wiadomość
ADI-mistrzu 


Distro: Titanium
Dołączył: 19 Paź 2005
Posty: 345
Skąd: Legionowo
Wysłany: 20 Czerwiec 2007, 18:50   Problem z RPM

Witam!

Ostatnio pojawiła się aktualizacja RPM więc pokusiłem się i ją zaktualizowałem... ale chyba była wadliwa bo teraz wogóle niemoge nic robić z RPM'ami.
Pojawia się taki komunikat:
Kod:

rpmdb: /var/lib/rpm/Packages: unexpected file type or format
błąd: nie można otworzyć indeksu Packages przy użyciu db3 - Zły argument (22)
błąd: nie można otworzyć bazy danych Packages w /var/lib/rpm


To błąd pakietu czy cos mam walnięte ? Przed updatem działało wszystko dobrze.
 
 
 
zajac 


Pomógł: 32 razy
Dołączył: 06 Lip 2005
Posty: 506
Skąd: Toruń
Wysłany: 20 Czerwiec 2007, 19:03   

zrób
Kod:
rpm --rebuilddb

i zacznie działać
_________________
Strony internetowe Toruń.
 
 
 
arkh 
użytkownik PLD


Pomógł: 9 razy
Dołączył: 24 Sie 2005
Posty: 219
Skąd: Warszawa
Wysłany: 20 Czerwiec 2007, 19:45   

Zasubskrybuj sobie grupy dyskusyjne (pl-devel i pl-user). Tam ten problem i rozwiązanie były poruszane kilka dni temu.
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group