PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Przesunięty przez: bioly
1 Czerwiec 2007, 10:38
[Th] Gnome i KDE su lub sudo
Autor Wiadomość
zalp 


Pomógł: 32 razy
Dołączył: 16 Gru 2005
Posty: 492
Wysłany: 27 Maj 2007, 19:02   [Th] Gnome i KDE su lub sudo

Problem taki:
Uruchamiam w Gnome przykładowo:
Kod:
[zalp@pldmachine ~]$ gksu users-admin

i wyskakuje mnie:
Kod:
(users-admin:4238): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

(users-admin:4238): Liboobs-WARNING **: There was an unknown error communicating with the backends: Message did not receive a reply (timeout by message bus)

(users-admin:4238): Liboobs-WARNING **: There was an unknown error communicating with the backends: Message did not receive a reply (timeout by message bus)

Gdzieś się coś ustawia, żeby działało?
_________________
Pozdrawiam
Ostatnio zmieniony przez zalp 30 Maj 2007, 18:52, w całości zmieniany 1 raz  
 
 
 
Fazi
[Usunięty]

Wysłany: 28 Maj 2007, 00:02   

spod usera
Kod:
$ xhost +

i powinno działać (przynajmniej do czasu restartu kompa). xhost jest w paczce `xorg-app-xhost`
 
 
zalp 


Pomógł: 32 razy
Dołączył: 16 Gru 2005
Posty: 492
Wysłany: 28 Maj 2007, 08:21   

Niestety, dalej to samo. :sad:
To znaczy, że pojawia się szata graficzna programu (okno), ale bez zawartości (okno jest puste).
_________________
Pozdrawiam
 
 
 
MegaBajt 

Distro: PLD 3.0
Pomógł: 23 razy
Dołączył: 10 Wrz 2005
Posty: 88
Skąd: Łódź
Wysłany: 28 Maj 2007, 16:52   

Nie będę ściemniał - nie działa. Obejść to można:
Kod:
# killall system-tools-backends

i z użytkownika:
Kod:
$ system-tools-backends

Teraz powinno uruchomić się poprawnie, ale nie wiem czy będzie działać.
_________________
Marcin Banasiak
 
 
zalp 


Pomógł: 32 razy
Dołączył: 16 Gru 2005
Posty: 492
Wysłany: 28 Maj 2007, 21:03   

Niestety, ale jest jakiś nowy komunikat:
Kod:
Nie można uruchomić users-admin jako użytkownik root.
Nie powiodła się komunikacja z gksu-run-helper.
Otrzymano:
 epoprawne hasło
Oczekiwano:
 gksu: waiting
_________________
Pozdrawiam
 
 
 
MietasSR 
OSx86... bezcenne.


Dołączył: 28 Maj 2007
Posty: 35
Wysłany: 30 Maj 2007, 13:18   

Mam podobny problem, tyle ze w KDE. Gdy probuje cos uruchomic przez kdesu, wywala mi takie cos:
Kod:
Komunikacja z 'su' przerwana.

Wie ktos jak temu zaradzic?
_________________
Jesli pomoglem kliknij przycisk helped, bardzo prosze :D
 
 
 
croolyc 
zajonc trejn


Pomógł: 25 razy
Dołączył: 06 Lip 2005
Posty: 985
Skąd: Polanów
Wysłany: 30 Maj 2007, 14:39   

mi kdesu nawet nic nie pisnie
klikam "tryb admin..." i nawet mnie o hasło nie pyta

próbowaliście dodać się do grupy wheel?
ewentualnie zmienic cos w /etc/sudoers
_________________
PLD - Punk Linux Distro
Underground Out Of Poland
 
 
 
MegaBajt 

Distro: PLD 3.0
Pomógł: 23 razy
Dołączył: 10 Wrz 2005
Posty: 88
Skąd: Łódź
Wysłany: 30 Maj 2007, 15:41   

MietasSR napisał/a:
Mam podobny problem, tyle ze w KDE. Gdy probuje cos uruchomic przez kdesu, wywala (...)

http://lists.pld-linux.or...ril/140701.html

PS.
Co kdesu ma do tematu tego wątku? :-)
_________________
Marcin Banasiak
 
 
zalp 


Pomógł: 32 razy
Dołączył: 16 Gru 2005
Posty: 492
Wysłany: 30 Maj 2007, 18:56   

Skoro treść wykracza poza temat, to należy zmienić temat. :wink:
_________________
Pozdrawiam
 
 
 
MietasSR 
OSx86... bezcenne.


Dołączył: 28 Maj 2007
Posty: 35
Wysłany: 30 Maj 2007, 19:18   

Najlepsze jest to, ze gdy skonfigurowalem sudo KDE wola o password usera :O Troche to dziwne, na innych distro sie z tym nie spotkalem. Ale to moze przez to, ze tu mam najaktualniejsze wersje pakietow jakie kiedykolwiek mialem :D
Z gory dzieki wszystkich za pomoc.
@zalp: Jestem za :D Moze bardziej odpowiedni bylby temat "Problemy z gksu i kdesu - tu pisac!" Ale to tylko propozycja :wink:
_________________
Jesli pomoglem kliknij przycisk helped, bardzo prosze :D
 
 
 
croolyc 
zajonc trejn


Pomógł: 25 razy
Dołączył: 06 Lip 2005
Posty: 985
Skąd: Polanów
Wysłany: 30 Maj 2007, 21:18   

na pewno dobrze skonfigurowałeś?
Kod:
root    ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
# %wheel        ALL=(ALL)       ALL

# Same thing without a password
%wheel  ALL=(ALL)       NOPASSWD: ALL
_________________
PLD - Punk Linux Distro
Underground Out Of Poland
 
 
 
zalp 


Pomógł: 32 razy
Dołączył: 16 Gru 2005
Posty: 492
Wysłany: 30 Maj 2007, 21:20   

MietasSR napisał/a:
Najlepsze jest to, ze gdy skonfigurowalem sudo KDE wola o password usera :O Troche to dziwne, na innych distro sie z tym nie spotkalem.

W /etc/sudoers:
Kod:
Defaults   rootpw

croolyc napisał/a:
# Same thing without a password
%wheel ALL=(ALL) NOPASSWD: ALL

Oj, nie wiem ...?
_________________
Pozdrawiam
 
 
 
Superbeer 

Dołączył: 09 Maj 2007
Posty: 35
Wysłany: 31 Maj 2007, 20:20   

Kod:
Komunikacja z 'su' przerwana.


Ja również otrzymuję powyższy komunikat gdy próbuję wchodzić w tryb administratora w apletach w Centrum Sterowania KDE. Próbowałem różnych sztuczek powyżej opisanych ale nic to nie daje.
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 31 Maj 2007, 22:13   

A próbowałeś szukać rozwiązania na forum? Mamy taką prostą wyszukiwarkę w lewym górnym rogu...
Zobacz http://forum.pld-linux.org/viewtopic.php?p=15722 z dalszymi linkami.
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group