PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Przesunięty przez: bioly
4 Czerwiec 2007, 12:43
[Th] claws-mail i ssl
Autor Wiadomość
johnny
[Usunięty]

Wysłany: 25 Maj 2007, 09:36   [Th] claws-mail i ssl

Witam,
Po instalacji mojego ulubionego klienta claws-mail pod Th pojawia się komunikat
Kod:

claws-mail: error while loading shared libraries: libssl.so.0.9.7: cannot open shared object file: No such file or directory


Tymczasem
Kod:

# rpm -qa | grep ssl
openssl-tools-perl-0.9.8e-4.i686
openssl-devel-0.9.8e-4.i686
openssl-static-0.9.8e-4.i686
openssl-tools-0.9.8e-4.i686
openssl-0.9.8e-4.i686


Pomyślałem, że zbuduję sobie z cvs bez ssl, bo niby po co mi to.
Jednak podczas próby dostaję:
Kod:

checking whether to use libetpan... yes
checking for libetpan-config... /usr/bin/libetpan-config
checking libetpan/libetpan.h usability... yes
checking libetpan/libetpan.h presence... yes
checking for libetpan/libetpan.h... yes
checking whether libetpan-config hints compiles and links fine... no
*** Claws Mail requires libetpan 0.48 or newer. See http://www.etpan.org/
*** You can use --disable-libetpan if you don't need IMAP4 support.
configure: error: libetpan 0.48 not found
błąd: Błędny status wyjścia z /tmp/rpm-tmp.26892 (%build)


Błędy budowania RPM-a:
    Błędny status wyjścia z /tmp/rpm-tmp.26892 (%build)
Error: package build failed. (no more info)


Czy można to jakoś naprawić?

Wiem, że mogę sobie zainstalować syplpeed, bo niby taki sam, ale jakoś clows nieco bardziej mi podchodzi.
Swoją drogą to widzę, że prace na sylpheed zostały wznowione i jest już znacznie nowsza wersja niż ta dostępna PLD.

Na marginesie jeszcze mała uwaga, bo zupełnie nie rozumiem dlaczego w Ac są dwie wersje claws-mail, które powodują nieco zamieszania, a czasami nawet problemów.
Podrawiam
 
 
MegaBajt 

Distro: PLD 3.0
Pomógł: 23 razy
Dołączył: 10 Wrz 2005
Posty: 88
Skąd: Łódź
Wysłany: 26 Maj 2007, 20:20   Re: [Th] claws-mail i ssl

Dobra, wklej jeszcze wynik:
Kod:
$ rpm -q --qf "%{name} %{epoch}:%{version}-%{release} %{buildhost}\n" claws-mail

Bo ten claws-mail nie wygląda na tego z Th.
johnny napisał/a:
Wiem, że mogę sobie zainstalować syplpeed, bo niby taki sam, ale jakoś clows nieco bardziej mi podchodzi.

To nie jest wyjście. Coś nie działa - należy zgłosić błąd. Deweloper nie jest jasnowidzem i nie wie o wszystkich błędach, które należy poprawić.
johnny napisał/a:
Na marginesie jeszcze mała uwaga, bo zupełnie nie rozumiem dlaczego w Ac są dwie wersje claws-mail, które powodują nieco zamieszania, a czasami nawet problemów.

Jakie dwie wersje? Jak przeszkadza to ustaw w poldek.conf by ignorował powtórzone pakiety.

PS.
Do zgłaszania błędów jest http://bugs.pld-linux.org/ . Nie każdy ma czas by przeczesywać listy, fora i inne tego typu w poszukiwaniu ewentualnych zgłoszeń.
_________________
Marcin Banasiak
 
 
johnny
[Usunięty]

Wysłany: 26 Maj 2007, 21:22   

Kod:

$ rpm -q --qf "%{name} %{epoch}:%{version}-%{release} %{buildhost}\n" claws-mail
claws-mail 0:2.9.1-1 th-i686.th.pld-linux.org

O to chodziło?

Cytat:

Jakie dwie wersje? Jak przeszkadza to ustaw w poldek.conf by ignorował powtórzone pakiety.

Jest claws-mail-2.7 i claws-mail-2.9 przy czym nie ma wszystkich plugin-ów do wersji 2.9

Cytat:

Do zgłaszania błędów jest http://bugs.pld-linux.org/ . Nie każdy ma czas by przeczesywać listy, fora i inne tego typu w poszukiwaniu ewentualnych zgłoszeń.

Ale nie jestem aż takim mocarzem żeby wiedzieć, czy to nie ja popełniam gdzieś błąd.Dlatego piszę na forum.
Pozdrawiam
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 26 Maj 2007, 21:34   

johnny napisał/a:
Jest claws-mail-2.7 i claws-mail-2.9 przy czym nie ma wszystkich plugin-ów do wersji 2.9
2.7 jest w main, a 2.9 w updates
_________________
Krystian T.
"Errare humanum est."
 
 
MegaBajt 

Distro: PLD 3.0
Pomógł: 23 razy
Dołączył: 10 Wrz 2005
Posty: 88
Skąd: Łódź
Wysłany: 26 Maj 2007, 22:48   

johnny napisał/a:
Kod:

$ rpm -q --qf "%{name} %{epoch}:%{version}-%{release} %{buildhost}\n" claws-mail
claws-mail 0:2.9.1-1 th-i686.th.pld-linux.org

Hm, moją teorię wzieło w łep. Do kompletu daj jeszcze:
Kod:
$ ldd /usr/bin/claws-mail

Może wystarczy przeinstalować claws-maila? Jak nie patrzeć, u mnie problem nie występuje...
_________________
Marcin Banasiak
 
 
johnny
[Usunięty]

Wysłany: 27 Maj 2007, 07:34   

Kod:

$ ldd /usr/bin/claws-mail
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb7f44000)
        libc.so.6 => /lib/libc.so.6 (0xb7e19000)
        libaspell.so.15 => /usr/lib/libaspell.so.15 (0xb7d5d000)
        libldap-2.3.so.0 => /usr/lib/libldap-2.3.so.0 (0xb7d29000)
        liblber-2.3.so.0 => /usr/lib/liblber-2.3.so.0 (0xb7d1d000)
        libpisock.so.9 => /usr/lib/libpisock.so.9 (0xb7cef000)
        libgnomeprintui-2-2.so.0 => /usr/lib/libgnomeprintui-2-2.so.0 (0xb7cb1000)
        libgnomeprint-2-2.so.0 => /usr/lib/libgnomeprint-2-2.so.0 (0xb7c4f000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb792b000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb78ae000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb7898000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb785c000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb7825000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7822000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7794000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb778c000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb7775000)
        libstartup-notification-1.so.0 => /usr/lib/libstartup-notification-1.so.0 (0xb776c000)
        libetpan.so.11 => /usr/lib/libetpan.so.11 (0xb76d6000)
        libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0xb7699000)
        libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb756d000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7556000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7526000)
        librt.so.1 => /lib/librt.so.1 (0xb751e000)
        /lib/ld-linux.so.2 (0xb7f59000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7519000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7437000)
        libm.so.6 => /lib/libm.so.6 (0xb7412000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7407000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb73f5000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb73df000)
        libusb-0.1.so.4 => /usr/lib/libusb-0.1.so.4 (0xb73d6000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb72c3000)
        libgnomecanvas-2.so.0 => /usr/lib/libgnomecanvas-2.so.0 (0xb729b000)
        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0xb7286000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb726d000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb7264000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb7257000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb724f000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb724c000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xb7244000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb723e000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb7234000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7230000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb71be000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb7195000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb716c000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7100000)
        libz.so.1 => /lib/libz.so.1 (0xb70ed000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb700b000)
        libssl.so.0.9.7 => not found
        libcrypto.so.0.9.7 => not found
        libdb-4.2.so => /lib/libdb-4.2.so (0xb6f38000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb6f35000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb6f12000)
        libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xb6f0e000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb6f06000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6ef0000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0xb6ed1000)
        libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb6ecf000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6ecb000)


Przeinstalowanie nie pomaga, robiłem to z 5 razy.
Pozdrawiam
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group