PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Nie wstający KDE - dziwne błędy
Autor Wiadomość
ADI-mistrzu 


Distro: Titanium
Dołączył: 19 Paź 2005
Posty: 345
Skąd: Legionowo
Wysłany: 8 Sierpień 2012, 10:52   Nie wstający KDE - dziwne błędy

Witam,

Ostatnio postawiłem Titanium na komputerze, wszystko poszło bardzo dobrze, X'y się postawiły, kdm ruszał bez większych błędów (jedyne błędy to niemożność załadowania dri, ale to gdzieś jest zaszyte jako opcja default oraz błąd o nie podłączonej wtyczce zasilania do karty).

Dorzuciłem KDE i za pierwszym razem wstało, ale okazało się że nie mam wszystkich czcionek więc wyłączyłem tryb graficzny, doinstalowałem je i KDE wyrzuca błędy podczas pruby ładowania Kwin:
Kod:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f6c52da7356 in QVariant::QVariant(QVariant const&) () from /usr/lib64/libQtCore.so.4
#6  0x00007f6c56d29997 in QDBusPendingReplyData::argumentAt(int) const () from /usr/lib64/libQtDBus.so.4
#7  0x00007f6c55885855 in ?? () from /usr/lib64/libkephal.so.4
#8  0x00007f6c55883569 in ?? () from /usr/lib64/libkephal.so.4
#9  0x00007f6c55876543 in ?? () from /usr/lib64/libkephal.so.4
#10 0x00007f6c55876ccd in Kephal::Screens::self() () from /usr/lib64/libkephal.so.4
#11 0x00007f6c55876d33 in Kephal::ScreenUtils::numScreens() () from /usr/lib64/libkephal.so.4
#12 0x00007f6c568f4f39 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#13 0x00007f6c568d928b in ?? () from /usr/lib64/libkdeinit4_kwin.so
#14 0x00007f6c568da0f3 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#15 0x00007f6c5651a0ad in __libc_start_main () from /lib64/libc.so.6
#16 0x0000000000400669 in _start ()

A po chwili pojawia się jeszcze błąd od plasmy:
Kod:
Application: Przestrzeń robocza Plazmy (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f2abed13356 in QVariant::QVariant(QVariant const&) () from /usr/lib64/libQtCore.so.4
#6  0x00007f2ac03f0997 in QDBusPendingReplyData::argumentAt(int) const () from /usr/lib64/libQtDBus.so.4
#7  0x00007f2ab1217855 in ?? () from /usr/lib64/libkephal.so.4
#8  0x00007f2ab1215569 in ?? () from /usr/lib64/libkephal.so.4
#9  0x00007f2ab1208543 in ?? () from /usr/lib64/libkephal.so.4
#10 0x00007f2ab1208ccd in Kephal::Screens::self() () from /usr/lib64/libkephal.so.4
#11 0x00007f2ab1208d33 in Kephal::ScreenUtils::numScreens() () from /usr/lib64/libkephal.so.4
#12 0x00007f2ab1b305b6 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#13 0x00007f2ab1b30885 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#14 0x00007f2ab1b1cd8c in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#15 0x0000000000406c18 in _start ()

I potem już co jakieś 3s. pokazuje się ten sam błąd:
Kod:
Application: Interfejs do uruchamiania poleceń (krunner), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f57448217a0 (LWP 5101))]

Thread 2 (Thread 0x7f5734267700 (LWP 5102)):
#0  0x00007f57442e28b3 in poll () from /lib64/libc.so.6
#1  0x00007f573bbadb43 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f573bbae38a in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f57347af996 in ?? () from /usr/lib64/libgio-2.0.so.0
#4  0x00007f573bbd4d16 in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f57408d3e45 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f57442ebced in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f57448217a0 (LWP 5101)):
[KCrash Handler]
#5  0x00007f5741fe3356 in QVariant::QVariant(QVariant const&) () from /usr/lib64/libQtCore.so.4
#6  0x00007f57449ed997 in QDBusPendingReplyData::argumentAt(int) const () from /usr/lib64/libQtDBus.so.4
#7  0x00007f5743ba1855 in ?? () from /usr/lib64/libkephal.so.4
#8  0x00007f5743b9f569 in ?? () from /usr/lib64/libkephal.so.4
#9  0x00007f5743b92543 in ?? () from /usr/lib64/libkephal.so.4
#10 0x00007f5743b92ccd in Kephal::Screens::self() () from /usr/lib64/libkephal.so.4
#11 0x00007f5743b92d33 in Kephal::ScreenUtils::numScreens() () from /usr/lib64/libkephal.so.4
#12 0x00007f57445c7c85 in ?? () from /usr/lib64/libkdeinit4_krunner.so
#13 0x00007f57445c8703 in ?? () from /usr/lib64/libkdeinit4_krunner.so
#14 0x00007f57445cf650 in ?? () from /usr/lib64/libkdeinit4_krunner.so
#15 0x00007f57445cbbe4 in ?? () from /usr/lib64/libkdeinit4_krunner.so
#16 0x00007f57445cc8d3 in ?? () from /usr/lib64/libkdeinit4_krunner.so
#17 0x00007f57445cc925 in ?? () from /usr/lib64/libkdeinit4_krunner.so
#18 0x00007f57445cd68d in kdemain () from /usr/lib64/libkdeinit4_krunner.so
#19 0x00007f574422f0ad in __libc_start_main () from /lib64/libc.so.6
#20 0x0000000000400669 in _start ()

Zauważyłem w trybie tekstowym że podczas logowania zwracało informację że system nie może znaleźć maszyny java, więc ją doinstalowałem i wtedy KDE znowu wstało, ale po ponownym uruchomieniu komputera znowu leży...

Widać że błędy odwołują się do biblioteki libthread_db z pakietu glibc, więc próbowałem go reinstalować ale bez skutku. Zainstalowałem także nowszą wersję z repozytorium develop, ale także nie pomogło.

Macie pomysł co może to powodować? KDE ma jakieś powiązanie z maszyną java?
 
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group