PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
gnome
Autor Wiadomość
xyz 

Dołączył: 21 Lip 2006
Posty: 108
Wysłany: 30 Sierpień 2008, 05:09   gnome

cześć,
nagrałem sobie Ti z cri-iso ale jak moge teraz nagrac gnome?

pozdrawiam

Update: zrobiem poldek --upgrade-dist a potem poldek install gnome* i dostaje ten błąd:
Kod:
glibc-2.16.5-1.i686:required "libfam.so.0" is provided by following packages:
a) fam-libs-2.7.0-7.i686
b) gamin-libs-0.1.9-1.i686


który mam wybrać?
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 30 Sierpień 2008, 06:38   

xyz napisał/a:
nagrałem sobie Ti z cri-iso ale jak moge teraz nagrac gnome?
Masz na myśli "zainstalować"? Nie wiem jak w Ti, ale w Th są metapakiety
Kod:
poldek:/all-avail> ls metapackage-gnome*
metapackage-gnome-2.22.3-1.noarch
metapackage-gnome-accessibility-2.22.3-1.noarch
metapackage-gnome-admin-2.22.3-1.noarch
metapackage-gnome-core-2.22.3-1.noarch
metapackage-gnome-desktop-2.22.3-1.noarch
metapackage-gnome-devtools-2.22.3-1.noarch
metapackage-gnome-office-2.22.3-1.noarch

Można zainstalować któryś z nich - to specjalne pakiety, które tylko ciągną odpowiednie zależności np.:
Kod:
poldek:/all-avail> desc -r metapackage-gnome-core

Package:        metapackage-gnome-core-2.22.3-1.noarch
Requires:       eog >= 2.22.3, fam, gedit2 >= 2.22.3, gnome-control-center >= 1:2.22.2.1, gnome-desktop >= 2.22.3,
    gnome-icon-theme >= 2.22.0, gnome-menus >= 2.22.2, gnome-panel >= 2.22.2, gnome-session >= 2.22.3,
    gnome-terminal >= 2.22.3, gtk2-engines >= 1:2.14.3, nautilus >= 2.22.4, yelp >= 2.22.1
Requires(rpm):  rpmlib(PayloadIsLzma) <= 4.4.6-1
Suggests:       metacity >= 2:2.22.0
Co do libfam to oba pakiety go zawierają, a gamin-libs ma dodatkowo jeszcze bibliotekę libgamin. Jak ci nie szkoda odrobiny miejsca na dysku to wybierz gamin-libs, jak wiesz na pewno, że gamina nie będziesz używał to możesz wybrać fam-libs. Zawsze też możesz później zmienić... Wybór należy do ciebie.
_________________
Krystian T.
"Errare humanum est."
 
 
xyz 

Dołączył: 21 Lip 2006
Posty: 108
Wysłany: 30 Sierpień 2008, 11:32   

wybrałem sobie metapackage-gnome-desktop ale nakóncu dostałem ten błąd:
Kod:

Executing rpm --upgrade -vh --root /...
error: Failed dependencies:
/usr/share/myspell is needed by xulrunner-1.9.0.1-1.i686
There were errors


Co trzeba teraz zrobić?
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 30 Sierpień 2008, 15:04   

poszukać co dostarcza brakującej rzeczy i zainstalować najodpowiedniejszą...
Kod:
[***** szukanie *****]

poldek:/all-avail> search -f /usr/share/myspell
Przeszukiwanie pakietów..........................................zrobione.
5 package(s) found:
icedove-2.0.0.16-1.i686
iceweasel-3.0.1-1.i686
myspell-common-1.0.2-11.noarch
openoffice.org-core-2.4.1.7-ooh680_m17.1.i686
xulrunner-1.9.0.1-1.i686

[***** sprawdzenie co jest w pakiecie *****]

poldek:/all-avail> desc -l myspell-common-1.0.2-11.noarch

Package:        myspell-common-1.0.2-11.noarch
/usr/share/myspell:  dictionary.lst

[***** instalacja *****]

poldek:/all-avail> install myspell-common-1.0.2-11.noarch
_________________
Krystian T.
"Errare humanum est."
 
 
xyz 

Dołączył: 21 Lip 2006
Posty: 108
Wysłany: 31 Sierpień 2008, 00:41   

A jak można teraz zakończyć instalacja od metapackage-gnome-desktop żeby nie trzeba było wszystkie pakiety jeszcze raz ściągać?
 
 
xyz 

Dołączył: 21 Lip 2006
Posty: 108
Wysłany: 31 Sierpień 2008, 06:34   

zrobiłem jeszcze raz "install metapackage-gnome-desktop" i zakończył bez wszystkiego na nowo sciągać.

no i spróbowałem startx ale dostaje błąd:
Kod:

command not found


Co brakuje jeszcze?
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 31 Sierpień 2008, 07:29   

xyz napisał/a:
Co brakuje jeszcze?
Nie podałem ci wcześniej sposobu na szukanie w poldku?
Kod:
poldek:/all-avail> search -f */startx
Przeszukiwanie pakietów..........................................zrobione.
1 package(s) found:
xorg-app-xinit-1.1.0-1.i686
_________________
Krystian T.
"Errare humanum est."
 
 
xyz 

Dołączył: 21 Lip 2006
Posty: 108
Wysłany: 31 Sierpień 2008, 12:47   

ops, za pomocą search -f /usr/bin/Xwrapper zainstalowałem sobie xorg-xserver-server.

Ale mam ten błąd

Zainstalowałem sobie Mesa-libGL bo mam starą ATI Radeon 9000.

Co brakuje jeszcze?
 
 
svl 
paweld


Pomógł: 115 razy
Dołączył: 19 Lis 2006
Posty: 1038
Skąd: Toruń
Wysłany: 31 Sierpień 2008, 13:33   

Brakuje Ci modułów, albo zakomentujesz je w xorg.conf [niektore mogą być niezbędne, np kbd, mouse] lub zainstalujesz odpowiednie paczki, znajdziesz je przy pomocy poldka, większość będzie wygladała mniej więcej tak: xorg-driver-video-fbdev/vga/vesa itd.
Zawsze warto też zerknąc do dokumentacji http://pl.docs.pld-linux.org/x_wstep.html
_________________
God, root, what is difference?
 
 
xyz 

Dołączył: 21 Lip 2006
Posty: 108
Wysłany: 26 Listopad 2008, 02:23   

Dziękuje wam.
Do tej instrukcji http://pl.docs.pld-linux.org/x_wstep.html trzeba dodać to http://www.pld-linux.org/...744f62ae49d41cf .
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group