PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Przesunięty przez: pooh
19 Lipiec 2007, 21:25
Problem z drukarką USB (Samsung ML-2010)
Autor Wiadomość
Tom 

Dołączył: 15 Gru 2005
Posty: 6
Wysłany: 17 Lipiec 2007, 14:04   Problem z drukarką USB (Samsung ML-2010)

Witam!
Problem mój dotyczy drukarki laserowej Samsung ML-2010, którą próbuję uruchomić na TH, niestety bez powodzenia.
Po podłączeniu drukarki dmesg zawiera
Kod:
usb 1-1: new full speed USB device using ohci_hcd and address 2
Device driver usbdev1.2_ep00 lacks bus and class support for being resumed.
usb 1-1: configuration #1 chosen from 1 choice
Device driver usbdev1.2_ep02 lacks bus and class support for being resumed.
Device driver usbdev1.2_ep83 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C


Niestety, polecenie lsusb nie wykazuje obecności drukarki
Kod:
[root@pldmachine ~]# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

"Dzięki" temu zjawisku nie mogę dodać drukarki w CUPS, gdyż nie jest tam wykrywana (cups-backend-usb mam oczywiście zainstalowany).


Dziwne jest to, iż kolejne wywołanie lsusb, ale nie później niż ~2 sekundy po wywołaniu wcześniejszym, pokazuje obecność drukarki
Kod:
[root@pldmachine ~]# date && lsusb && date && sleep 2 && lsusb && sleep 5 && date && lsusb
Wt, 17 VII 2007, 14:06:09 CEST
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Wt, 17 VII 2007, 14:06:09 CEST
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 029: ID 04e8:326c Samsung Electronics Co., Ltd
Bus 001 Device 001: ID 0000:0000
Wt, 17 VII 2007, 14:06:16 CEST
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000


Po kilku takich wywołaniach lsusb dmesg zawiera
Kod:
sb 1-1: new full speed USB device using ohci_hcd and address 5
Device driver usbdev1.5_ep00 lacks bus and class support for being resumed.
usb 1-1: configuration #1 chosen from 1 choice
Device driver usbdev1.5_ep02 lacks bus and class support for being resumed.
Device driver usbdev1.5_ep83 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C
usb 1-1: USB disconnect, address 5
drivers/usb/class/usblp.c: usblp0: removed
usb 1-1: new full speed USB device using ohci_hcd and address 6
Device driver usbdev1.6_ep00 lacks bus and class support for being resumed.
usb 1-1: configuration #1 chosen from 1 choice
Device driver usbdev1.6_ep02 lacks bus and class support for being resumed.
Device driver usbdev1.6_ep83 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 6 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C
usb 1-1: USB disconnect, address 6
drivers/usb/class/usblp.c: usblp0: removed
usb 1-1: new full speed USB device using ohci_hcd and address 7
Device driver usbdev1.7_ep00 lacks bus and class support for being resumed.
usb 1-1: configuration #1 chosen from 1 choice
Device driver usbdev1.7_ep02 lacks bus and class support for being resumed.
Device driver usbdev1.7_ep83 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C
usb 1-1: USB disconnect, address 7
drivers/usb/class/usblp.c: usblp0: removed
usb 1-1: new full speed USB device using ohci_hcd and address 8
Device driver usbdev1.8_ep00 lacks bus and class support for being resumed.
usb 1-1: configuration #1 chosen from 1 choice
Device driver usbdev1.8_ep02 lacks bus and class support for being resumed.
Device driver usbdev1.8_ep83 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 8 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C
usb 1-1: USB disconnect, address 8
drivers/usb/class/usblp.c: usblp0: removed
usb 1-1: new full speed USB device using ohci_hcd and address 9
Device driver usbdev1.9_ep00 lacks bus and class support for being resumed.
usb 1-1: configuration #1 chosen from 1 choice
Device driver usbdev1.9_ep02 lacks bus and class support for being resumed.
Device driver usbdev1.9_ep83 lacks bus and class support for being resumed.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 9 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C

Wygląda to tak, jakby drukarka była kilka razy odłączana/podłączana :-(

Poza tym, w /proc/bus/usb/devices drukarka jest przez cały czas widoczna
Kod:
[root@pldmachine ~]# cat /proc/bus/usb/devices

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 8
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.21.3-1 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:0b.1
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 8
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.21.3-1 ohci_hcd
S:  Product=OHCI Host Controller
S:  SerialNumber=0000:00:0b.0
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  8 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=04e8 ProdID=326c Rev= 1.00
S:  Manufacturer=Samsung
S:  Product=Samsung ML-2010
S:  SerialNumber=3T21BKDP221471B.
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms


Załadowane moduły
Kod:
[root@pldmachine ~]# lsmod
Module                  Size  Used by
usblp                  12416  0
parport                31816  0
x25                    40592  0
appletalk              32428  0
ipx                    25508  0
p8023                   2560  1 ipx
netrom                 38560  0
ax25                   53968  1 netrom
ipv6                  257472  10
nvidia               7239828  26
agpgart                27988  1 nvidia
button                  6800  0
sch_sfq                 6016  2
wlan_tkip              11392  1
nls_cp852               5632  3
vfat                   11392  3
fat                    46364  1 vfat
nls_iso8859_2           5376  4
ntfs                  220096  1
eth1394                17412  0
sr_mod                 15268  0
cdrom                  34976  1 sr_mod
amd74xx                14364  0 [permanent]
wlan_scan_sta          11008  1
ath_rate_sample        12544  1
generic                 5252  0 [permanent]
ide_core              117064  2 amd74xx,generic
snd_hda_intel          17432  1
snd_hda_codec         211456  1 snd_hda_intel
serio_raw               6148  0
rtc_cmos                7828  0
snd_pcm                69764  2 snd_hda_intel,snd_hda_codec
snd_timer              19716  1 snd_pcm
forcedeth              44680  0
rtc_core                8068  1 rtc_cmos
k8temp                  5376  0
snd                    44772  6 snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
psmouse                35592  0
pcspkr                  3584  0
rtc_lib                 3968  1 rtc_core
hwmon                   3332  1 k8temp
soundcore               6752  1 snd
ath_pci                82720  0
sdhci                  15756  0
i2c_nforce2             5888  0
wlan                  172336  5 wlan_tkip,wlan_scan_sta,ath_rate_sample,ath_pci
mmc_core               22404  1 sdhci
ohci1394               32176  0
tifm_7xx1               7424  0
tifm_core               7296  1 tifm_7xx1
ieee1394               84664  2 eth1394,ohci1394
i2c_core               17792  2 nvidia,i2c_nforce2
snd_page_alloc          8456  2 snd_hda_intel,snd_pcm
ath_hal               229856  3 ath_rate_sample,ath_pci
ehci_hcd               31500  0
pata_amd               10892  0
ohci_hcd               20100  0
usbcore               116744  4 usblp,ehci_hcd,ohci_hcd
ata_generic             6148  0
tsdev                   6976  0
evdev                   8832  6
sata_nv                16132  6
libata                103828  3 pata_amd,ata_generic,sata_nv
ext3                  123016  1
mbcache                 7428  1 ext3
jbd                    52520  1 ext3
scsi_wait_scan          2176  0
sd_mod                 18688  7
scsi_mod               92684  4 sr_mod,libata,scsi_wait_scan,sd_mod


Wykluczam w tym wypadku problem sprzętowy, gdyż drukarka działa poprawnie pod Windows oraz po zbootowaniu komputera z PLD Rescue CD 2.01 lsusb poprawnie (przy każdym wywołaniu) wykrywa obecność drukarki.

Czy ktokolwiek ma pomysł, co może powodować tego typu problem i ewenualnie w jaki sposób go rozwiązać?
 
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group