PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
Przesunięty przez: pooh
28 Czerwiec 2007, 22:42
Th i glibc
Autor Wiadomość
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 28 Czerwiec 2007, 21:42   Th i glibc

Witam :)

mam pewien problem - dotyczy TH i glibc. Sciagnąłem rescue 2.90 i odpaliłem ... zrobiłem wszystko co trzeba do instalacji, wchodzę do poldka z odpowiednimi parametrami, wypisuję listę paczek do zainstalowaina i go...

pare razy wywala mi błąd i kończy instalację bez żadnej instalacji. A oto ten błąd:

Kod:

error: glibc-2.6-5: req uname(release) >= 2.6.12 not found
1 unsatisfied dependencies found
error: Buggy package set


wszystko robie poprawnie - ac wstaje ... co dziwniejsze ... pewna osoba jakiś czas temu miała podobny problem i nagle ten problem się rozwiązał ... u mnie tak jest cały czas.

druga ciekawostka ... ta sama osoba instaluje Th z rescue 2.90 bez problemu .... nie melduje jej błędu z glibc ---> czy ktoś wie o co chodzi ???

dodam jeszcze, może to ważne ... obaj mamy rożnych dostawców internetowych ... ja mam toye ... może to wina toyi ???

miał ktoś podobny problem ??? jeśli tak to jak to rozwiązał ??? oraz jak to rozwiązać ???

proszę o pomysły bo moje już się skończyły :(
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 28 Czerwiec 2007, 21:49   

Zainstaluj tego glibc z parametrem --nodeps
sar4er napisał/a:
obaj mamy rożnych dostawców internetowych
Z tego powodu możecie trafiać do innych mirrorów. Teoretycznie mogły być (bądź tylko jeden z nich) nie zaktualizowane wtedy, gdy robiliście instalację i jeden miał ten błąd, a drugi nie...
_________________
Krystian T.
"Errare humanum est."
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 28 Czerwiec 2007, 21:51   

zrobiłem tak ... zainstalowało mimo tego samego błędu ... sciągneło też inne paczki ...

a dalej mam zrobić normalną instalkę ??
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 28 Czerwiec 2007, 22:07   

sar4er napisał/a:
a dalej mam zrobić normalną instalkę ?
Tak, a w razie dalszych problemów pisz, tylko najlepiej nowy problem == nowy wątek...
_________________
Krystian T.
"Errare humanum est."
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 28 Czerwiec 2007, 22:21   

Krystian T. napisał/a:

Z tego powodu możecie trafiać do innych mirrorów. Teoretycznie mogły być (bądź tylko jeden z nich) nie zaktualizowane wtedy, gdy robiliście instalację i jeden miał ten błąd, a drugi nie...

ech ... czyli mam pecha i ciągle przekierowywuje mnie do ftp, który nie jest zaktualizowany :(
w takim wypadku pozostaje tylko czekać :P ...

nie ma to jak mieć szczęście :)
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 28 Czerwiec 2007, 22:33   

Cytat:
ech ... czyli mam pecha i ciągle przekierowywuje mnie do ftp, który nie jest zaktualizowany :(
w takim wypadku pozostaje tylko czekać
Nie musisz czekać - możesz sobie wymusić z jakiego serwera chcesz korzystać przez odpowiednie wpisy w /etc/hosts:
Kod:
#217.73.31.20   ftp.pld-linux.org
#153.19.42.122  ftp.pld-linux.org
#81.95.106.52   ftp.pld-linux.org
#217.149.246.5  ftp.pld-linux.org

Kiedys tak miałem i odkomentowywałem tego, którego chciałem używać...
Adresy serwerów to:
Kod:
[krystian@laptom ~]$ host ftp.pld-linux.org
ftp.pld-linux.org is an alias for ftp.sk2.pld-linux.org.
ftp.sk2.pld-linux.org has address 217.73.31.17
[krystian@laptom ~]$ host ftp1.pld-linux.org
ftp1.pld-linux.org is an alias for ftp.sk.pld-linux.org.
ftp.sk.pld-linux.org is an alias for ep09.pld-linux.org.
ep09.pld-linux.org has address 217.73.31.20
[krystian@laptom ~]$ host ftp2.pld-linux.org
ftp2.pld-linux.org is an alias for fly.mif.pg.gda.pl.
fly.mif.pg.gda.pl has address 153.19.42.122
i tak jeszcze kilka numerków...
_________________
Krystian T.
"Errare humanum est."
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 28 Czerwiec 2007, 22:41   

o kurde :) ... tego nie wiedziałem :)

to tak przy okazji ... gdzie znajdę aktualne mirrory serwerów ???
oraz może ktoś podać te najszybciej aktualizowane i pewne ???
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 28 Czerwiec 2007, 23:35   

czegoś tutaj nie rozumiem ...

sprawdziłem wszystkie adresy, mirrory jakie znalazłem i mam ten sam błąd !!

czy ja mam tylko takiego pecha czy naprawde jest coś nie tak ???
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 28 Czerwiec 2007, 23:58   

sar4er napisał/a:
gdzie znajdę aktualne mirrory serwerów

http://pld-linux.org/Mirrors
sar4er napisał/a:
najszybciej aktualizowane i pewne
master-ftp...
A błąd jest związany z rpm-em http://lists.pld-linux.or...ary/064608.html i mam wrażenie, że już kiedyś czytałem rozwiązanie...
_________________
Krystian T.
"Errare humanum est."
 
 
zalp 


Pomógł: 32 razy
Dołączył: 16 Gru 2005
Posty: 492
Wysłany: 29 Czerwiec 2007, 07:50   

sar4er napisał/a:
pare razy wywala mi błąd i kończy instalację bez żadnej instalacji. A oto ten błąd:
Kod:
error: glibc-2.6-5: req uname(release) >= 2.6.12 not found
1 unsatisfied dependencies found
error: Buggy package set

Mnie się wydaje, że problem jest w pakiecie:
Kod:
glibc-localedb-all

Jeżeli jest on instalowany razem z resztą glibc* to problemów nie ma. Z upgrade'ami też problemów nie powinno być. Problemy są jak nie ma tej paczki w zestawie do zainstalowania lub upgradu.
Zaznaczam, że pewności nie mam. Przyczyny tego też nie są mnie znane. :mrgreen:
_________________
Pozdrawiam
 
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 29 Czerwiec 2007, 11:45   

zalp napisał/a:

Mnie się wydaje, że problem jest w pakiecie:
Kod:
glibc-localedb-all

Jeżeli jest on instalowany razem z resztą glibc* to problemów nie ma. Z upgrade'ami też problemów nie powinno być. Problemy są jak nie ma tej paczki w zestawie do zainstalowania lub upgradu.
Zaznaczam, że pewności nie mam. Przyczyny tego też nie są mnie znane. :mrgreen:


niestety ... dodanie tego pakietu do instalacji nadal powoduje błąd o którym pisałem ... może u innych to działa ... lecz nie u mnie :(
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 29 Czerwiec 2007, 20:22   

nie wiem już co się dzieje.... zmieniałem mirrory, kombinowałem i nic ... nadal ten sam błąd.

podejrzewam, że to chodzi o mojego dostawce internetowego ... ktoś mi powiedział, że oni wszystko keszuja ... może to jest wina??? najgorsze jest to, że ja nic nie mogę z tym zrobić :(

więc zainstalować TH nie mogę :( ... a biegać z każdym komputerem do innej osoby (mającej innego providera) po to żeby zainstalować TH mija się z celem :(
 
 
arekm
[Usunięty]

Wysłany: 29 Czerwiec 2007, 21:30   

Instalujesz jak rozumiem w jakimś katalogu przez poldek --root /costam? Jeśli tak to spróbuj zamontować proca w /costam/proc przed odpaleniem poldka.
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 29 Czerwiec 2007, 21:46   

sar4er napisał/a:
więc zainstalować TH nie mogę
Nawet z --nodeps dla glibc?
_________________
Krystian T.
"Errare humanum est."
 
 
sar4er 

Pomógł: 1 raz
Dołączył: 28 Cze 2007
Posty: 45
Wysłany: 30 Czerwiec 2007, 00:05   

nawet ... wywala mi błąd z db ... juz nie pamietam jaki :(
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group