PLD Linux Forum Strona Główna PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj

Poprzedni temat «» Następny temat
GNOME - nie dziala :(
Autor Wiadomość
MietasSR 
OSx86... bezcenne.


Dołączył: 28 Maj 2007
Posty: 35
Wysłany: 18 Czerwiec 2007, 15:09   GNOME - nie dziala :(

Witam. Mam problem. Otoz niedawno chcialem sie przerzucic na GNOME, jednak nie dziala na userze :( Zalozylem nowego usera i dziala, jednak ja chce zeby dzialalo na moim starym userze :( Wywala blad, dotyczy to KBD, nie wiem o co mu chodzi, wszystko inne smiga xD
Pomozcie!
W miare mozliwosci zedytuje posta i dam komunikat bledu.
GNOME nie dziala (wedlug mnie), bo panel w ogole sie nie laduje i nie widze nic. Na roocie i innym userze wszystko OK.

Dystrybucja: PLD Th
Pakiety od X:
Kod:

[mietassr_pl@pldmachine ~]$ rpm -qa | grep xorg | grep -v devel | grep -v static | sort
xorg-app-iceauth-1.0.1-1.athlon
xorg-app-rgb-1.0.1-1.athlon
xorg-app-sessreg-1.0.2-5.athlon
xorg-app-xauth-1.0.2-3.athlon
xorg-app-xdpyinfo-1.0.2-1.athlon
xorg-app-xinit-1.0.4-1.athlon
xorg-app-xkbcomp-1.0.3-1.athlon
xorg-app-xkbevd-1.0.2-1.athlon
xorg-app-xkbutils-1.0.1-1.athlon
xorg-app-xkill-1.0.1-1.athlon
xorg-app-xmodmap-1.0.2-1.athlon
xorg-app-xprop-1.0.2-1.athlon
xorg-app-xvinfo-1.0.1-1.athlon
xorg-data-xbitmaps-1.0.1-1.athlon
xorg-driver-input-keyboard-1.1.1-0.1.athlon
xorg-driver-input-mouse-1.2.1-1.athlon
xorg-driver-video-nv-2.0.96-1.athlon
xorg-driver-video-nvidia-1.0.9755-2.athlon
xorg-font-font-adobe-100dpi-1.0.0-1.athlon
xorg-font-font-adobe-75dpi-1.0.0-1.athlon
xorg-font-font-alias-1.0.1-1.athlon
xorg-font-font-cursor-misc-1.0.0-1.athlon
xorg-font-font-misc-misc-1.0.0-4.athlon
xorg-font-font-misc-misc-ISO8859-2-1.0.0-4.athlon
xorg-font-font-misc-misc-base-1.0.0-4.athlon
xorg-lib-libICE-1.0.3-1.athlon
xorg-lib-libSM-1.0.3-1.athlon
xorg-lib-libX11-1.1.1-3.athlon
xorg-lib-libXScrnSaver-1.1.2-1.athlon
xorg-lib-libXau-1.0.3-1.athlon
xorg-lib-libXaw-1.0.3-1.athlon
xorg-lib-libXcomposite-0.3.2-1.athlon
xorg-lib-libXcursor-1.1.8-3.athlon
xorg-lib-libXdamage-1.1.1-1.athlon
xorg-lib-libXdmcp-1.0.2-4.athlon
xorg-lib-libXext-1.0.3-1.athlon
xorg-lib-libXfixes-4.0.3-3.athlon
xorg-lib-libXfont-1.2.8-1.athlon
xorg-lib-libXft-2.1.12-2.athlon
xorg-lib-libXi-1.1.0-3.athlon
xorg-lib-libXinerama-1.0.2-1.athlon
xorg-lib-libXmu-1.0.3-3.athlon
xorg-lib-libXp-1.0.0-3.athlon
xorg-lib-libXpm-3.5.6-3.athlon
xorg-lib-libXrandr-1.2.1-1.athlon
xorg-lib-libXrender-0.9.2-3.athlon
xorg-lib-libXres-1.0.3-1.athlon
xorg-lib-libXt-1.0.5-2.athlon
xorg-lib-libXtst-1.0.1-3.athlon
xorg-lib-libXv-1.0.3-1.athlon
xorg-lib-libXxf86dga-1.0.1-3.athlon
xorg-lib-libXxf86misc-1.0.1-3.athlon
xorg-lib-libXxf86vm-1.0.1-3.athlon
xorg-lib-libdmx-1.0.2-3.athlon
xorg-lib-libfontenc-1.0.4-1.athlon
xorg-lib-libxkbfile-1.0.4-3.athlon
xorg-lib-libxkbui-1.0.2-3.athlon
xorg-xserver-server-1.3.0.0-4.athlon
xorg-xserver-xgl-0.0.20060711-3.athlon
[mietassr_pl@pldmachine ~]$



Wszystkie zainstalowane pakiety GNOME:
Kod:

[mietassr_pl@pldmachine ~]$ rpm -qa | grep gnome | grep -v devel | grep -v static | sort
gnome-applets-2.18.0-1.athlon
gnome-desktop-2.18.1-1.athlon
gnome-desktop-libs-2.18.1-1.athlon
gnome-icon-theme-2.18.0-1.noarch
gnome-keyring-0.8.1-1.athlon
gnome-keyring-libs-0.8.1-1.athlon
gnome-media-2.18.0-1.athlon
gnome-media-libs-2.18.0-1.athlon
gnome-menus-libs-2.18.0-1.athlon
gnome-panel-2.18.1-1.athlon
gnome-panel-libs-2.18.1-1.athlon
gnome-session-2.18.0-2.athlon
gnome-splash-gnome-2.18.0-2.athlon
gnome-terminal-2.18.0-1.athlon
gnome-themes-2.18.1-1.athlon
gnome-utils-2.18.1-1.athlon
gnome-utils-screenshot-2.18.1-1.athlon
gnome-utils-search-tool-2.18.1-1.athlon
gnome-vfs2-2.18.1-1.athlon
gnome-vfs2-libs-2.18.1-1.athlon
libgnome-2.18.0-1.athlon
libgnomecanvas-2.14.0-5.athlon
libgnomekbd-2.18.1-1.athlon
libgnomeprint-2.18.0-1.athlon
libgnomeprintui-2.18.0-1.athlon
libgnomeui-2.18.1-1.athlon
[mietassr_pl@pldmachine ~]$



Mam nadzieje ze te listy pakietow beda pomocne :) Moze mi brakuje jakiegos pakietu?

Pozdrawiam i prosze o pomoc.
_________________
Jesli pomoglem kliknij przycisk helped, bardzo prosze :D
 
 
 
MegaBajt 

Distro: PLD 3.0
Pomógł: 23 razy
Dołączył: 10 Wrz 2005
Posty: 88
Skąd: Łódź
Wysłany: 18 Czerwiec 2007, 17:36   

Bez komunikatu błędu do niczego się nie dojdzie. Dodatkowo pomocna będzie zawartość ~/.xsession-errors po próbie uruchomienia GNOME.
_________________
Marcin Banasiak
 
 
MietasSR 
OSx86... bezcenne.


Dołączył: 28 Maj 2007
Posty: 35
Wysłany: 18 Czerwiec 2007, 18:43   

OK, juz pisze co GNOME wywala po uruchomieniu:
Kod:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10300000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd



.xsession-errors :
Kod:

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "mietassr_pl"
/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession[165]: xmodmap: not found
/etc/gdm/Xsession: ssh-agent not found!
/etc/gdm/Xsession: Setup done, will execute: gnome-session
SESSION_MANAGER=local/pldmachine:/tmp/.ICE-unix/4614
Window manager warning: Failed to load theme "Clearlooks": Failed to find a valid file for theme Clearlooks

Window manager warning: Failed to load theme "Simple": Failed to find a valid file for theme Simple

Window manager warning: Failed to load theme "Default": Failed to find a valid file for theme Default

Window manager warning: Failed to load theme "Emacs": Failed to find a valid file for theme Emacs

Window manager warning: Failed to load theme "Raleigh": Failed to find a valid file for theme Raleigh

Window manager warning: Failed to load theme "superkaramba": Failed to find a valid file for theme superkaramba


** (gnome-session:4614): WARNING **: Host name lookup failure on localhost.
Window manager warning: Could not create directory '/home/mietassr_pl/.metacity/sessions': Permission denied
Window manager warning: Could not open session file '/home/mietassr_pl/.metacity/sessions/1181394331-4643-3376149187.ms' for writing: Permission denied

(nautilus:4650): gnome-vfs-modules-WARNING **: failed to create trash item cache file

(nautilus:4650): gnome-vfs-modules-WARNING **: failed to create trash item cache file
Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on display ':0.0'.
nautilus: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

_________________
Jesli pomoglem kliknij przycisk helped, bardzo prosze :D
 
 
 
MegaBajt 

Distro: PLD 3.0
Pomógł: 23 razy
Dołączył: 10 Wrz 2005
Posty: 88
Skąd: Łódź
Wysłany: 18 Czerwiec 2007, 19:22   

Kod:
Window manager warning: Could not create directory '/home/mietassr_pl/.metacity/sessions': Permission denied
Window manager warning: Could not open session file '/home/mietassr_pl/.metacity/sessions/1181394331-4643-3376149187.ms' for writing: Permission denied

Z prawami wszystko ok?
_________________
Marcin Banasiak
 
 
MietasSR 
OSx86... bezcenne.


Dołączył: 28 Maj 2007
Posty: 35
Wysłany: 18 Czerwiec 2007, 20:53   

Raczej tak, nie dawno wyeliminowalem wszystkie problemy z prawami (wlasnie od gnome). Nie wiem skad to sie wzielo, ale sprobuje zrobic chmod 777 i zobacze :)
_________________
Jesli pomoglem kliknij przycisk helped, bardzo prosze :D
 
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 19 Czerwiec 2007, 22:25   

Jeżeli na nowym userze działa to zainstalowane masz wszystko co trzeba. Możesz sobie spróbować zrobić
Kod:
mv ~/.metacity ~/kopia.metacity
i zobaczyć czy ci się uruchomi
_________________
Krystian T.
"Errare humanum est."
 
 
jefe 

Pomógł: 7 razy
Dołączył: 14 Sty 2006
Posty: 392
Wysłany: 19 Czerwiec 2007, 22:44   

Może spróbuj zrobić chown -R nazwa_użytkownika /katalog_użytkownika
 
 
MietasSR 
OSx86... bezcenne.


Dołączył: 28 Maj 2007
Posty: 35
Wysłany: 26 Czerwiec 2007, 18:50   

Wszystko co napisaliście już zrobiłem. Niestety, dalej nie działa :D
PS. Nie patrzcie na to, że jestem na Ubuntu. Siedzę u brata na LiveCD, a on ma Windę na lapku :/ A bez linuksa nie mogę pracować przy kompie :D
_________________
Jesli pomoglem kliknij przycisk helped, bardzo prosze :D
 
 
 
KrystianT 

Distro: PLD 3.0
Pomógł: 189 razy
Dołączył: 26 Paź 2005
Posty: 1920
Skąd: Kamionek
Wysłany: 26 Czerwiec 2007, 18:59   

Właśnie porównałem listę plików gnome i ja mam jeszcze
gnome-common-2.18.0-1.noarch
-- edit -- ale w/g opisu nie powinien być potrzebny
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group