PLD Linux Forum
Oficjalne forum dystrybucji PLD Linux

Serwer - [HOWTO] Postfix + greylisting (bez bazy danych)

shadzik - 18 Styczeń 2007, 19:54
Temat postu: [HOWTO] Postfix + greylisting (bez bazy danych)
Witam,

Na prośbę sivego takie oto króciutkie howto.
Uwaga: zakładam, że użytkownik ma trochę śluzu mózgowego między uszami i poprawnie skonfigurowanego postfiksa - np. wg pl.docs.pld-linux.org.
Zaczynamy.

Nie będę tłumaczył czym jest greylisting bo od tego mamy wikipedię i cały internet (google.com).

Zacznijmy od instalacji postgrey.

#poldek -iv postgrey --noask

Edytujemy /etc/mail/main.cf ulubionym edytorem i w linijce smtpd_recipient_restrictions = ... dopisujemy check_policy_service unix:/var/spool/postfix/postgrey/socket.
By utrudnić spamerowi połączenie z naszym MTA dopiszmy jeszcze jedną linijkę w tym pliku: smtpd_data_restrictions = reject_unauth_pipelining

Startujemy postgreya i restartujemy postfiksa:
service postgrey start
service postfix restart

Jesteśmy w domu. Od tej pory mam w /etc/mail/ kilka whitelist które możemy aczkolwiek nie musimy edytować (dopisuje się tam podejrzane hosty).
Pozdrawiam. Jeśli coś pominąłem, o czymś zapomniałem - proszę mi zwrócić uwagę w prywatnej wiadomości. Dziękuję.

karat611 - 25 Styczeń 2007, 09:04

Witam,
zrobiłem dokładnie to co opisał kolega powyżej ale niestety przestała mi poczta wysyłac maile. Łączy się z serwerem ale nie wysyła.
Po zablokowaniu wpisu unix:/var/spool/postfix/postgrey/socket wszystko wraca do normy.

Czy ktoś ma jakiś pomysł czemu się tak dzieje??

Z gry dziękuje za pomoc

jędrek - 25 Styczeń 2007, 17:32

karat611 napisał/a:
Witam,
zrobiłem dokładnie to co opisał kolega powyżej ale niestety przestała mi poczta wysyłac maile. Łączy się z serwerem ale nie wysyła.
Po zablokowaniu wpisu unix:/var/spool/postfix/postgrey/socket wszystko wraca do normy.

Czy ktoś ma jakiś pomysł czemu się tak dzieje??

Z gry dziękuje za pomoc


Zapewne dlatego, że ten socket z paczki z AC jest zupełnie gdzie indziej ;)
A mianowicie mieści się w: /var/run/greylistd/socket

shadzik - 25 Styczeń 2007, 18:05

dŁUGi napisał/a:
Zapewne dlatego, że ten socket z paczki z AC jest zupełnie gdzie indziej ;)
A mianowicie mieści się w: /var/run/greylistd/socket


Raczej nie. Dowód ?:
[root@entermedia ~]# ls -l /var/spool/postfix/postgrey/socket
srw-rw-rw- 1 postgrey nobody 0 2006-11-15 06:18 /var/spool/postfix/postgrey/socket
[root@entermedia ~]# rpm -qf /var/spool/postfix/postgrey/
postgrey-1.27-2
[root@entermedia ~]#

Ty używasz greylistd, a ja postgreya przeznaczonego specjalnie dla postfixa.

karat611, jakieś logi poproszę. Wróżką nie jestem.

[UPDATE]
karat611, ok, już widzę. Błąd z mojej strony oczywiście:
należy dodać "check_policy_service unix:/var/spool/postfix/postgrey/socket". Już <del>poprawiam</del> <ins>poprawiłem</ins> w opisie.

jędrek - 25 Styczeń 2007, 18:13

shadzik napisał/a:
dŁUGi napisał/a:
Zapewne dlatego, że ten socket z paczki z AC jest zupełnie gdzie indziej ;)
A mianowicie mieści się w: /var/run/greylistd/socket


Raczej nie. Dowód ?:
[root@entermedia ~]# ls -l /var/spool/postfix/postgrey/socket
srw-rw-rw- 1 postgrey nobody 0 2006-11-15 06:18 /var/spool/postfix/postgrey/socket
[root@entermedia ~]# rpm -qf /var/spool/postfix/postgrey/
postgrey-1.27-2
[root@entermedia ~]#

Ty używasz greylistd, a ja postgreya przeznaczonego specjalnie dla postfixa.

karat611, jakieś logi poproszę. Wróżką nie jestem.

[UPDATE]
karat611, ok, już widzę. Błąd z mojej strony oczywiście:
należy dodać "check_policy_service unix:/var/spool/postfix/postgrey/socket". Już poprawiam w opisie.


Fakt. Mój błąd. Przepraszam za zamieszanie. Zwracam honor :)

baslow - 10 Październik 2007, 16:16

Dzieki za fajny manualik postgrey dziala bez pudla... znaczy dziala ale mi sie franca uczy adresow jak juz raz przejdzie mail to go pozniej puszcza bez odczekania 5 minut jak to mozna naprawic?

W pliku:
Kod:
/etc/rc.d/init.d/postgrey


Zrobilem cos takiego:
Kod:
OPTIONS="--unix=/var/spool/postfix/postgrey/socket --auto-whitelist-clients=0 --lookup-by-host"


Wydawalo mi sie z dokumentacji i tego co znalazlem ze to wystarczy a jednak nie. Co jeszcze powinienem zmienic, jak skonfigurowac zeby kazdy adres byl zawsze sprawdzany oraz zeby sprawdzanie napewno bylo po hoscie a nie subnecie?

Aha opcje dodane przeze mnie napewno dobrze sie dokladaja do wywolania postgrey'a
Kod:
# ps aux | grep postgrey
postgrey 10954  0.0  0.7  10804  7948 ?        SNs  10:32   0:00 /usr/sbin/postgrey -d --unix=/var/spool/postfix/postgrey/socket --auto-whitelist-clients=0 --lookup-by-host

baslow - 21 Październik 2007, 17:08

Sorki ze tak mecze ale moze ktos jest w stanie mi pomoc i odpowiedziec na moje pytania??
Dzieki.

syed20 - 30 Sierpień 2014, 06:24
Temat postu: sultan
Dzieki za fajny manualik postgrey dziala bez pudla... znaczy dziala ale mi sie franca uczy adresow jak juz raz przejdzie mail to go pozniej puszcza bez odczekania 5 minut jak to mozna naprawic?

Powered by phpBB modified by Przemo © 2003 phpBB Group